Topic: problem with flash banner

Hi!
I 'm workig on my private site now, and I've made flash banner for it...but when I tied to validate my site, w3c validator throws me errors about embed and parameters     inside embed flag, that it can't be used at all... how can I do to repair this? I     know, that it can be rebuild somehow, I've seen sth like that on http://www.salagedata.com. There are animated element in header, but page is 100% validated. Thanks for your help

Re: problem with flash banner

justyna wrote:

Hi!
I 'm workig on my private site now, and I've made flash banner for it...but when I tied to validate my site, w3c validator throws me errors about embed and parameters     inside embed flag, that it can't be used at all... how can I do to repair this? I     know, that it can be rebuild somehow, I've seen sth like that on http://www.salagedata.com. There are animated element in header, but page is 100% validated. Thanks for your help

... you should look in page source and it will be all clear ...

Re: problem with flash banner

lukaszw wrote:
justyna wrote:

Hi!
I 'm workig on my private site now, and I've made flash banner for it...but when I tied to validate my site, w3c validator throws me errors about embed and parameters     inside embed flag, that it can't be used at all... how can I do to repair this? I     know, that it can be rebuild somehow, I've seen sth like that on http://www.salagedata.com. There are animated element in header, but page is 100% validated. Thanks for your help

... you should look in page source and it will be all clear ...

I've looked in page source, and I can't understand one thing...ok, it's a gif file inserted instead swf and there is img instead embed, but why in IE, when I enter site I can see swf not gif....how is that??

Re: problem with flash banner

justyna wrote:
lukaszw wrote:
justyna wrote:

Hi!
I 'm workig on my private site now, and I've made flash banner for it...but when I tied to validate my site, w3c validator throws me errors about embed and parameters     inside embed flag, that it can't be used at all... how can I do to repair this? I     know, that it can be rebuild somehow, I've seen sth like that on http://www.salagedata.com. There are animated element in header, but page is 100% validated. Thanks for your help

... you should look in page source and it will be all clear ...

I've looked in page source, and I can't understand one thing...ok, it's a gif file inserted instead swf and there is img instead embed, but why in IE, when I enter site I can see swf not gif....how is that??

Ok, I see you're a noobie... look, this is a source code from www.salagedata.com:

    <object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,29,0" width="69" height="70">
        <param name="movie" value="http://www.salvagedata.com/templates/sd2007s/images/127.swf" />
        <param name="quality" value="high" />
        <img src="http://www.salvagedata.com/templates/sd2007s/images/salv.gif" width="69" height="69" alt=" "/>
    </object>

you can see, that there is gif file in <img>, but you should look inside param's too, so

        <param name="movie" value="http://www.salvagedata.com/templates/sd2007s/images/127.swf" />

as you can see here is swf file inserted and IE displaying that file, instead animated gif ...

Re: problem with flash banner

lukaszw wrote:
justyna wrote:
lukaszw wrote:

... you should look in page source and it will be all clear ...

I've looked in page source, and I can't understand one thing...ok, it's a gif file inserted instead swf and there is img instead embed, but why in IE, when I enter site I can see swf not gif....how is that??

Ok, I see you're a noobie... look, this is a source code from www.salagedata.com:

    <object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,29,0" width="69" height="70">
        <param name="movie" value="http://www.salvagedata.com/templates/sd2007s/images/127.swf" />
        <param name="quality" value="high" />
        <img src="http://www.salvagedata.com/templates/sd2007s/images/salv.gif" width="69" height="69" alt=" "/>
    </object>

you can see, that there is gif file in <img>, but you should look inside param's too, so

        <param name="movie" value="http://www.salvagedata.com/templates/sd2007s/images/127.swf" />

as you can see here is swf file inserted and IE displaying that file, instead animated gif ...

Thanks for your help:)

Re: problem with flash banner

justyna wrote:
lukaszw wrote:
justyna wrote:

I've looked in page source, and I can't understand one thing...ok, it's a gif file inserted instead swf and there is img instead embed, but why in IE, when I enter site I can see swf not gif....how is that??

Ok, I see you're a noobie... look, this is a source code from www.salagedata.com:

    <object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,29,0" width="69" height="70">
        <param name="movie" value="http://www.salvagedata.com/templates/sd2007s/images/127.swf" />
        <param name="quality" value="high" />
        <img src="http://www.salvagedata.com/templates/sd2007s/images/salv.gif" width="69" height="69" alt=" "/>
    </object>

you can see, that there is gif file in <img>, but you should look inside param's too, so

        <param name="movie" value="http://www.salvagedata.com/templates/sd2007s/images/127.swf" />

as you can see here is swf file inserted and IE displaying that file, instead animated gif ...

Thanks for your help:)

smile