Topic: Rails not installing correctly.

I thought I would give rails a try and learn a new programming language at the same time. When I try to install rails I get this
C:\ruby\bin>gem install rails
Install required dependency activerecord? [Yn]  y
ERROR:  While executing gem ... (OpenURI::HTTPError)
    404 Not Found
Further snooping around in the repository revealed it is trying to install a gem for activerecord 1.5.6 which does not exist.
I had previously gotten rails working (yesterday) but formatted last night.

EDIT: I realized that it is trying to install a newly uploaded gem for rails, and the depency's don't exist in the repo yet. So I forced it to install the previous version using gem install rails -v o.9.4 and it worked like a charm.

Will upgrading using gems be seamless when the dependency do show up?

Last edited by kurisu (2007-11-24 14:58:04)

Re: Rails not installing correctly.

You installed Rails Version 0.9.4 ? wow, that's VERY old.

Latest stable release is 1.2.5, you should install this version. You shouldn't have any problems with this version.

Re: Rails not installing correctly.

Woops, I was looking at the wrong page. Thats why I saw 0.9.4. Well, thanks

Should I use Ruby 1.86 26 RC2 or 1.86 25?

EDIT: Well, seems activerecord 1.15.6 was uploaded in the 30 seconds, so its installing fine now.

Last edited by kurisu (2007-11-24 15:13:23)