Topic: `/rails/info/properties' not found.

I run my Restful with:

rake rails:freeze:gems instead of rake rails:freeze:edge because I the edge failed.
After run the upgrade to the new version of Rails got:

`/rails/info/properties' not found.

I use the following command:

./generate scaffold_resource Post name:string

This will get me start creating a simple Blog site. Trying to go to:

./script/server [ I noticed Mongrel did not start as supposed on EDGE ]

http://127.0.0.1:3000 Works but show the error message.

Later if try to access http://127.0.0.1:300/posts

From the Log File of the Server Got the error:

[2007-01-24 19:22:11] ERROR `/rails/info/properties' not found.
127.0.0.1 - - [24/Jan/2007:19:22:11 CST] "GET /rails/info/properties HTTP/1.1" 404 291
- -> /rails/info/properties

- -> /rails/info/properties
#<ArgumentError: Anonymous modules have no name to be referenced by>
["./script/../config/../vendor/rails/activesupport/lib/active_support/dependencies.rb:405:in `to_constant_name'", "./script/../config/../vendor/rails/activesupport/lib/active_support/dependencies.rb:215:in `qualified_name_for'", "./script/../config/../vendor/rails/activesupport/lib/active_support/dependencies.rb:477:in `const_missing'", "./script/../config/../vendor/rails/railties/lib/dispatcher.rb:117:in `reset_after_dispatch'", "./script/../config/../vendor/rails/railties/lib/dispatcher.rb:51:in `dispatch'", "./script/../config/../vendor/rails/railties/lib/webrick_server.rb:113:in `handle_dispatch'", "./script/../config/../vendor/rails/railties/lib/webrick_server.rb:79:in `service'", "/usr/lib/ruby/1.8/webrick/httpserver.rb:104:in `service'", "/usr/lib/ruby/1.8/webrick/httpserver.rb:65:in `run'", "/usr/lib/ruby/1.8/webrick/server.rb:173:in `start_thread'", "/usr/lib/ruby/1.8/webrick/server.rb:162:in `start'", "/usr/lib/ruby/1.8/webrick/server.rb:162:in `start_thread'", "/usr/lib/ruby/1.8/webrick/server.rb:95:in `start'", "/usr/lib/ruby/1.8/webrick/server.rb:92:in `each'", "/usr/lib/ruby/1.8/webrick/server.rb:92:in `start'", "/usr/lib/ruby/1.8/webrick/server.rb:23:in `start'", "/usr/lib/ruby/1.8/webrick/server.rb:82:in `start'", "./script/../config/../vendor/rails/railties/lib/webrick_server.rb:63:in `dispatch'", "./script/../config/../vendor/rails/railties/lib/commands/servers/webrick.rb:59", "/usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `gem_original_require'", "/usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'", "./script/../config/../vendor/rails/activesupport/lib/active_support/dependencies.rb:496:in `require'", "./script/../config/../vendor/rails/activesupport/lib/active_support/dependencies.rb:343:in `new_constants_in'", "./script/../config/../vendor/rails/activesupport/lib/active_support/dependencies.rb:496:in `require'", "./script/../config/../vendor/rails/railties/lib/commands/server.rb:39", "./script/server:3:in `require'", "./script/server:3"]
[2007-01-24 19:22:46] ERROR `/posts/' not found.
127.0.0.1 - - [24/Jan/2007:19:22:46 CST] "GET /posts/ HTTP/1.1" 404 276
- -> /posts/

Thank in advance for the advise.

Best Regards Dino.

Re: `/rails/info/properties' not found.

Seems like there is some bug with the Latest and greatest until today of gems...

I uninstall and reinstall in RHEL 4.0 and Windows XP from scratch, it toke a while to figure it out... but noticed Webbrick works great with Nested Resources when instal Mongrel the application quit working on the Nested Resources, I'm not sure if that use the gems upgrade or something related from Mongrel to gems... I'm not really clear on which files everything is connected together.

Just want to leave the not to keep heads up with the buggy upgrade LOL

This is the error after upgarde to Mongrel:
no route found to match "/rails/info/properties" with {:method=>:get}

After remove Mongrel with gem uninstall mongrel and start with WebBrick
The application is no longer working sad

Dino.