Topic: New Hivelogic Rails Install (Mac OS X)

Looks like the Hivelogic Tutorial for installing Rails has been updated! If you're on Mac OS X you may have used the old one. This new one looks much better. Say hello to Mongrel!

Interestingly it has you install Capistrano but there's no mention of Subversion. Fortunately that's easy with this package.

Railscasts - Free Ruby on Rails Screencasts

Re: New Hivelogic Rails Install (Mac OS X)

Having followed the Hivelogic tutorial successfully before, I thought I'd try the new and improved recipe with added mongrel. So I followed all the steps and things seemed to work okay, but now when I try to start the server, it tells me:

./script/../config/boot.rb:29:Warning: require_gem is obsolete.  Use gem instead.

It then says that it's has started but that 'It might not work well.' Then when I actually try and do anything with my rails app, it gives me the following few lines:

dyld: NSLinkModule() error
dyld: Symbol not found: _rl_filename_completion_function
  Referenced from: /usr/local/lib/ruby/1.8/i686-darwin8.8.1/readline.bundle
  Expected in: flat namespace

Trace/BPT trap

I've looked around to find that other people have experienced a similar problem, but none of the fixes offered have helped me. I'm fairly new to rails. Can anyone help?

Update: I ran 'gem update --system' and now all is working well.

Last edited by phiradash (2007-02-04 12:46:14)

Re: New Hivelogic Rails Install (Mac OS X)

Sorry you had this problem.

As I am a rubyrails newbie (and probably about to post lots of questions; though not until I have read through this forum) I just followed the same recipe and had total success.

Hope you sort it out. being able to use my Mac rather than a PC to do development is sooo wonderful.


Re: New Hivelogic Rails Install (Mac OS X)

I can't even get to first base with the path statement!  i am installing on OS/X server 10.4.9.  I was logged in as Administrator but have tried as root - same problem.  There is no /.bash_login file so I create one.  But when I try to run the file i get an error "permission denied".

gi19871:~ root# ~/.bash_login
-sh: /private/var/root/.bash_login: Permission denied

Any clues?

Re: New Hivelogic Rails Install (Mac OS X)

duh...  I missed the leading dot...  ". ~/.bash_login" - so user friendly (not)...

Re: New Hivelogic Rails Install (Mac OS X)

I am almost at the end of the installation process, but get an error right at the end...

gi19871:/usr/local/src/readline-5.1 administrator$ sudo gem install rails --include-dependencies
Bulk updating Gem source index for:
ERROR:  While executing gem ... (Gem::GemNotFoundException)
    Could not find rails (> 0) in any repository
gi19871:/usr/local/src/readline-5.1 administrator$

Did i miss something?

Re: New Hivelogic Rails Install (Mac OS X)

I found a fix at

Could not find rails (> 0) in any repository
Submitted by Derek Anderson on Wed, 2007-05-09 18:48. Hacking | Web Apps
The problem is solved by following the instructions here: Delete Your RubyGems Cache. Here is the secret sauce:

gem env
#which will give you something like this:
RubyGems Environment:
  - VERSION: 0.9.2 (0.9.2)
  - INSTALLATION DIRECTORY: /usr/lib/ruby/gems/1.8
     - /usr/lib/ruby/gems/1.8
Next you type the following:

rm -f /PATH/TO/GEM/PATH/FROM/ABOVE/source_cache

And then try the installation again.

There are more steps if you still have problems.