Topic: 500 errors no matter what I try to go to

I've had a look around and tried various things suggested (particularly the tutorial on 500 errors on the forum) but I can't find something to solve my problem.

I've finally gotten around to writing some views so I wanted to see how they were working.  Only, no matter what I try to go to, I'm getting the public/500.html file pop up (the one that says: "Application error Change this error message for exceptions thrown outside of an action (like in Dispatcher setups or broken Ruby code) in public/500.html").

I've tried this with webrick on my linux box and now mongrel (via instantrails) on my windows box.  The same error is happening so I'm guessing it's something in my config, but I can't work out what.  I haven't particularly changed any of the config files (as far as I remember).  The only think I have done is do rake:freeze:edge (or whatever the command is) - could this be causing the problem?

Re: 500 errors no matter what I try to go to

what do you see on your server console (terminal window where you startet your mongrel or webrick server)? there should be an error message.
Or have a look at your logfile (log/development.log)

Re: 500 errors no matter what I try to go to

I wasn't getting any errors before. I don't know if it's because of the way I was running the server.  I am now, however (at the moment it's not finding the database - but that could be because of the change in computer).  I'll see if fixing this problem solves it.

Re: 500 errors no matter what I try to go to

Yay!  That seemed to fix it.  Strange that I wasn't getting errors on the other machine.  Of course now I've got numerous other problems but at least it's managing to run the program.  Thanks!

Re: 500 errors no matter what I try to go to

Hi guys,

I recently upgraded to rails 1.2.2. To be more precise: I upgraded from ruby 1.8.4-20, rails 1.1.6 to ruby 1.8.5-22, rails 1.2.2, gem 0.9.2 under windows using webrick.
No matter what I'm trying to GET (except static stuff), a mapping error occurs and leads to a 500.
The basic problem seems to be a broken mapping between controller files and the actually addressed containing class. Usually the error message for e.g. addressing http://localhost:3000/welcome results in

Expected ./script/../config/../app/controllers/welcome_controller.rb to define WelcomeController

To make things easy to test and as you can see in the stack trace, I want to mention that I found out that clicking "About your application

Last edited by 4lex (2007-02-11 10:32:49)

Re: 500 errors no matter what I try to go to

I'm going through this myself with one of my projects.. 3 work fine but the 4th.. ug!  I haven't started narrowing things down yet, but take a look at your plugins and see if maybe they're using outdated code (e.g. observers) which may be causing you problems.

You should also make sure your gems package is up to date: … -2-upgrade

Re: 500 errors no matter what I try to go to

I had this issue too after upgrading to rails 1.2.  I was using a login engine plugin
and it does not work anymore.  My understanding is that it is
related to the Auto-loading feature which has changed.  See: … lebrations

Due to this Auto-loading change, it detected errors in my code where I missed
some require 'xxx' (ie, I was relying on that in a library code).  After fixing this
by adding the necessary require 'xxx', my code (that uses active support) worked alone
(command line).  I guess the login engine I'm using has the same issue but for now I've
simply removed it and it's ok.