Topic: 1.1.5 upgrade problems

I've updated rails to v1.1.5, but mongrel just isn't happy..

If I type rails -v in terminal, it says 1.1.5. If I make a new rails project and view the environment info section, it says 1.1.5. If i use WEBrick, it works, but if i try to start the mongrel server, it says "Cannot find gem for Rails =1.1.5: Install the missing gem with 'gem install -v=1.1.5 rails', or change environment.rb to define RAILS_GEM_VERSION with your desired version."

I'm completely mystified as to what's happening. Everything seems fine, bar mongrel.

Anyone have any ideas as to how I might get it working again?

Re: 1.1.5 upgrade problems

There should be a line in your config/environment.rb file that says

RAILS_GEM_VERSION = '1.some.number'

Change '1.some.number' to '1.1.5', then restart webrick/mongrel.

If that doesn't work, you can try freezing rails 1.1.5 into your application itself. Go to your app's root directory in a terminal and type this:

rake rails:freeze:gems TAG=rel_1.1.5

That will check out Rails 1.1.5 and put it in your app's /vendor directory, so it will use Rails 1.1.5 wherever you may happen to run the app.

vinnie - rails forum admin

Re: 1.1.5 upgrade problems

Cheers, Vin... I'd already changed the rails version number in the enviroment.rb, but hadn't tried freezing the gems, so I made a new project, froze the gems and mongrel works.

I thought i'd give mongrel one last try on the offending project which I've been having issues with before freezing the gems and it worked! Very strange considering I haven't changed anything in that project since I last tried to start mongrel and it failed. Oh well, at least it works now. It seems really odd that it's been playing up in this way, though..

Re: 1.1.5 upgrade problems

In Rails 1.2 Mongrel will take precedence over WEBrick when running script/server as well, so now's as good a time as any to start using it.

vinnie - rails forum admin