Topic: subversion issues when updating

fwiw, a word of warning: if you have a rails project under svn, be sure that you do *not* have the log, script, and tmp folders under repository control. And think twice about your vendor folder, you may want to exclude it, also.

I'm three days post-upgrade to ruby1.8.5.24/gem09.2/rails1.2.2, and am still in a serious pickle because of the above -- no problems working with the project, but svn is taking such good care of its data that i still haven't figured out how to get it working again (tortoise client).

Things are locked/obstructed and clean-up fails -- and now svn claims my apps folder is "not a working copy directory".

Re: subversion issues when updating


Here's what I had to do -- the offending folders were doc, log, script, tmp, vendor. Take the new ones from your newly-updated rails project and copy them somewhere else, locally.

Browse the repository (i use tortoise) and delete log, script, tmp, vendor -- i want to take these out permanently.  Doc I still want to version so i left it there.

I ran cleanup on the working copy, and it actually managed to clean up this time.

Then I committed, and it worked too, although complaining about the missing folders, above. Then, since I had already deleted the four folders I didn't want in the repository already, I ran a checkout to be sure my working copy was sync'd.

Next, copy your four folders from your local hiding place back into the project.  Note that script is quite important since it has rails-revision-dependent data. Data in the other folders can always be regenerated. With tortoise, flag the four folders so that they are ignored.

Finally, do another commit -- in my case it was clean (except for committing ".") and I do believe I'm good to go.