Topic: problem starting WEBrick

When I try to start WEBrick I get the following error.

./script/../config/boot.rb:29: undefined method `gem' for main:Object (NoMethodE
rror)
        from C:/InstantRails/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require
.rb:21:in `require'
        from script/server:2

I have installed Rails through instant rails, and was following the book: how to build your own RoR web applications. And I tried to start WEBrick with:
C:\InstantRails\rails_apps\shovell>ruby script/server

What to do??

Last edited by Jaap Bakker (2007-02-26 19:30:32)

Re: problem starting WEBrick

I think what's happening is that your gems version is not up to date.  You'll need to be on gems 0.9.2.  Why don't you reinstall gems and then see if that fixes your issue?  You may also need to erase your source_cache and do a gem update again. 

http://www.urbanpuddle.com/articles/200 … -2-upgrade

Re: problem starting WEBrick

I have updated my gems to version 0.9.4 but it still doesn't work. So maybe I need to remove my source_cache but it doesn't recognize the following commands which were given in the link you gave me.

Im in:
/usr/local/lib/ruby/gems/1.8/gems/

then I type: sudo rm -rf source cache

just as the site said, but it doesn't recognise the command. Does anyone know what to do?

Re: problem starting WEBrick

I found the problem. I had to update ruby gems with the following command from the InstantRails root folder.

gem update --system