Topic: Swapping between Windows and Linux

I'm not sure if this is strictly speaking a deployment issue but it is regarding moving a rails app between two machines.

I'm mostly developing on Windows because that's all I have at work, however when I get the chance to work from home I use Linux.  I'm using RoRED on Windows (and InstantRails) and Cream (vim) on Linux.

I've noticed occasional compatibility issues before but today they seem to be going crazy.  The only recent change is that I now have the acts_as_ferret plugin and the appropriate ferret gem on each system.  Since coming back from my Linux box this morning various pages are just showing up blank.  The first page to do so was the search page that I was working on.  I tried re-writing the page but that didn't work.  Finally I managed to copy some code from elsewhere that does a similar thing and this worked.  I now can't see another page which was working fine on Windows yesterday and which I swear I haven't touched today.  I'm not getting any errors up.

Can anyone think of any reason why there may be problems?  If it makes any different I'm using SVN to move files between the two.  But then, this file hasn't been changed or anything in the last couple of days.

Re: Swapping between Windows and Linux

Okay, I don't think this has anything to do with the transfer but to do with mongrel.  I have a page with a drop-down box which uses ajax to display a different partial depending on which option is selected.  The other day one option wasn't appearing so I assumed I'd broken something.  Today the other option isn't appearing.  I switched to webrick and all the pages I was having hassles with are fine.

Re: Swapping between Windows and Linux

Okay.. I'm now getting weird blank pages with webrick.

The only thing I can think of that could potentially effect any page (and it does seem to be random pages) is requiring ferret in environment.rb and using acts_as_ferret in a few of my models.  The main pages that don't seem to be displaying (currently) are list pages of various models, and a show page for one specific id.

Could ferret/acts_as_ferret be causing such weirdness?

Re: Swapping between Windows and Linux

Check the logs, are you getting compile errors on your templates?  If you are, you might want to have a look at  It's caused by acts_as_ferret but other plugins have the same problem (rmagik from what i hear too).

Re: Swapping between Windows and Linux

Thanks.  That definitely looks like the problem.  Shame I can't develop in Linux at work... unless I try the VMWare route... *ponders*