Topic: Rails requires RubyGems

Hi,

When i open the rails application by netbeans i got the error as below,

"Rails requires RubyGems >= 1.3.1 (you have 1.2.0). Please `gem update --system` and try again."

I tried by "gem update --system" also the gems updated to version 1.3.5. But the problem still exists

I have the ruby version "ruby 1.8.7 (2009-04-08 patchlevel 160) [i686-linux]"

And the below list are gem list

actionmailer (2.3.5)
actionpack (2.3.5)
activerecord (2.3.5)
activeresource (2.3.5)
activesupport (2.3.5)
fastercsv (1.5.0)
linecache (0.43)
rack (1.0.1)
rails (2.3.5)
rake (0.8.7)
ruby-debug-base (0.10.2)
ruby-debug-ide (0.3.1)
rubygems-update (1.3.5)

How can i fix the error. Did i miss anything?.

Thanks,
Periyasamy

Last edited by Periyasamy (2010-01-23 00:17:15)

Re: Rails requires RubyGems

I followed the steps described here:
http://www.hackido.com/2009/11/install- … armic.html
to install Ruby/RoR environment and everything works fine. Hope this helps you.

Last edited by Javix (2010-01-26 05:49:29)