Topic: undefined method 'set_preference' for nil:NilClass

New problem, when I try to run this command I get the following.
Any idea where and what I should be looking for to fix this?

latest spree, ruby, rails, gems. Works fine on my development machine.

rake RAILS_ENV=production db:schema:load --trace
(in /home/don/public_html/eastcoastcarvers.com/public/releases/20100319033623)
** Invoke db:schema:load (first_time)
** Invoke environment (first_time)
** Execute environment
rake aborted!
undefined method `set_preference' for nil:NilClass
/usr/lib/ruby/gems/1.8/gems/spree-0.10.1/lib/preference_access.rb:18:in `set'
/usr/lib/ruby/gems/1.8/gems/spree-0.10.1/lib/preference_access.rb:17:in `each'
/usr/lib/ruby/gems/1.8/gems/spree-0.10.1/lib/preference_access.rb:17:in `set'
/home/don/public_html/eastcoastcarvers.com/public/releases/20100319033623/vendor/extensions/theme_east_coast_carvers1/config/initializers/theme_east_coast_carvers1.rb:1
/usr/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:147:in `load_without_new_constant_marking'
/usr/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:147:in `load'
/usr/lib/ruby/gems/1.8/gems/spree-0.10.1/lib/spree/extension_loader.rb:110:in `run_initializers'
/usr/lib/ruby/gems/1.8/gems/spree-0.10.1/lib/spree/extension_loader.rb:108:in `each'
/usr/lib/ruby/gems/1.8/gems/spree-0.10.1/lib/spree/extension_loader.rb:108:in `run_initializers'
/usr/lib/ruby/gems/1.8/gems/spree-0.10.1/lib/spree/extension_loader.rb:107:in `each'
/usr/lib/ruby/gems/1.8/gems/spree-0.10.1/lib/spree/extension_loader.rb:107:in `run_initializers'
/usr/lib/ruby/gems/1.8/gems/spree-0.10.1/lib/spree/initializer.rb:126:in `after_initialize'
/usr/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:179:in `process'
/usr/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:113:in `send'
/usr/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:113:in `run'
/usr/lib/ruby/gems/1.8/gems/spree-0.10.1/lib/spree/initializer.rb:90:in `run'
/home/don/public_html/eastcoastcarvers.com/public/releases/20100319033623/config/environment.rb:13
/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require'
/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:in `require'
/usr/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:in `require'
/usr/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:521:in `new_constants_in'
/usr/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:in `require'
/usr/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/tasks/misc.rake:4
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:636:in `call'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:636:in `execute'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:631:in `each'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:631:in `execute'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:597:in `invoke_with_call_chain'
/usr/lib/ruby/1.8/monitor.rb:242:in `synchronize'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:590:in `invoke_with_call_chain'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:607:in `invoke_prerequisites'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:604:in `each'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:604:in `invoke_prerequisites'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:596:in `invoke_with_call_chain'
/usr/lib/ruby/1.8/monitor.rb:242:in `synchronize'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:590:in `invoke_with_call_chain'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:583:in `invoke'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2051:in `invoke_task'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2029:in `top_level'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2029:in `each'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2029:in `top_level'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2068:in `standard_exception_handling'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2023:in `top_level'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2001:in `run'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2068:in `standard_exception_handling'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:1998:in `run'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/bin/rake:31
/usr/bin/rake:19:in `load'
/usr/bin/rake:19

Re: undefined method 'set_preference' for nil:NilClass

So I removed my custom made theme and I made it past this point.
Again, I have no problems on my mac with this, just the server.

d

Re: undefined method 'set_preference' for nil:NilClass

I have the same problem with the latest release of Spree. How/Why would you remove your custom theme?