Topic: Capistrano problem on MediaTemple

Hi,

I have been trying to get set up with Capistrano for deploying my rails app to a MediaTemple Grid Server, but so far have had no luck, even after reading the famed tutorial at http://blog.vixiom.com/2007/02/18/mt-ro … ia-temple/ . The initial app creating and setup seem to have worked, since cap mt_add and cap setup were successful. I used the deployment recipe provided by (mt), but then when I try to do cap update_code, I get the following error:

/home/xxxx/data/rubygems/gems/gems/capistrano-1.4.1/lib/capistrano/scm/subversion.rb:24:in `latest_revision

Re: Capistrano problem on MediaTemple

I'm getting the same result.
Have you found a solution yet?
I'm using the MT grid server too.

Re: Capistrano problem on MediaTemple

I posted a cap recipe that I use here:

http://www.almosteffortless.com/2007/01 … ia-temple/

It sounds like your error is related to your subversion repo not be available. That could be a problem with the server, or maybe you're not giving it the right password, etc.

You can try to deploy with an application that you know has a public repo, like this:

http://svn.techno-weenie.net/projects/beast/trunk/

... just to see if it works.