Topic: Heroku db:push

Hi,

yesterday night i tried to port an existing application to heroku. Deployment worked fine. db:migrate also.

Then I wanted to push the data from my local environment to the production server via heroku db:push.

But then I got following errors:

Matthias-Nitschs-MacBook-Pro:squando.com matthias$ heroku db:push Loaded Taps v0.3.11 Auto-detected local database: postgres://matthias:12345@localhost:5432/squando_development?encoding=utf8
Warning: Data in the app 'squando' will be overwritten and will not be recoverable.
Are you sure you wish to continue? (y/n)? y Sending schema /Library/Ruby/Gems/1.8/gems/taps-0.3.11/bin/schema:3:in `require': no such file to load -- rubygems (LoadError)
    from /Library/Ruby/Gems/1.8/gems/taps-0.3.11/bin/schema:3
/Library/Ruby/Gems/1.8/gems/taps-0.3.11/bin/schema:3:in `require': no such file to load -- rubygems (LoadError)
    from /Library/Ruby/Gems/1.8/gems/taps-0.3.11/bin/schema:3
Schema:        100% |==========================================| Time: 00:00:01
/Library/Ruby/Gems/1.8/gems/taps-0.3.11/bin/schema:3:in `require': no such file to load -- rubygems (LoadError)
    from /Library/Ruby/Gems/1.8/gems/taps-0.3.11/bin/schema:3
/Library/Ruby/Gems/1.8/gems/json_pure-1.4.5/lib/json/pure/parser.rb:148:in `parse': source did not contain any JSON! (JSON::ParserError)
    from /Library/Ruby/Gems/1.8/gems/json_pure-1.4.5/lib/json/common.rb:146:in `parse'
    from /Library/Ruby/Gems/1.8/gems/taps-0.3.11/lib/taps/operation.rb:410:in `push_indexes'
    from /Library/Ruby/Gems/1.8/gems/taps-0.3.11/lib/taps/operation.rb:388:in `run'
    from /Library/Ruby/Gems/1.8/gems/taps-0.3.11/lib/taps/cli.rb:164:in `clientxfer'
    from /Library/Ruby/Gems/1.8/gems/heroku-1.9.13/lib/heroku/commands/db.rb:156:in `taps_client'
    from /Library/Ruby/Gems/1.8/gems/heroku-1.9.13/lib/heroku/commands/db.rb:13:in `push'
    from /Library/Ruby/Gems/1.8/gems/heroku-1.9.13/lib/heroku/command.rb:48:in `send'
    from /Library/Ruby/Gems/1.8/gems/heroku-1.9.13/lib/heroku/command.rb:48:in `run_internal'
    from /Library/Ruby/Gems/1.8/gems/heroku-1.9.13/lib/heroku/command.rb:20:in `run'
    from /Library/Ruby/Gems/1.8/gems/heroku-1.9.13/bin/heroku:13
    from /usr/bin/heroku:19:in `load'
    from /usr/bin/heroku:19

Anybody here who ca say something to that?

Thanks in advance.

Matthias

Re: Heroku db:push

Rubygems on Heroku was giving me troubles last night too. Seems to work fine today.

Re: Heroku db:push

Okay...tried it this morning at 8:30 Europe Time and it didn't work. So I will try it again tonight when I'm home from the office.