Topic: Problem(Error) in ruby-on rails installtion

To install the ruby-on rails on my computer i used the following commands in terminal

1)sudo apt-get install build-essentail (completed successfully)

2)sudo apt-get install ruby-full (completed successfully)

3)Download the rubygems-1.3.7.tgz  in download directory and the
   
                      cd Downloads
                      sudo tar -xvzf rubygems-1.3.7.tgz
                      cd rubygems-1.3.7
                     ruby setup.rb                                     (completed successfully)


4)  Then change directory as
                             cd /usr/bin
                                          Then typed

                             sudo gem install rails --version 2.3.2 --include-dependencies                                 

                                              After this command ,i got the following error


               
                  amrit@amrit-desktop:~$ cd /usr/bin
                  amrit@amrit-desktop:/usr/bin$ sudo gem install rails --version 2.3.2 --include-dependencies;
                  [sudo] password for amrit:
                   ERROR:  Loading command: install (LoadError)
                   no such file to load -- zlib
                   ERROR:  While executing gem ... (NameError)
                   uninitialized constant Gem::Commands::InstallCommand
                 amrit@amrit-desktop:/usr/bin$



Please somebody help to resolve it

Thanks in advance

Re: Problem(Error) in ruby-on rails installtion

see installation instructions here: http://www.hackido.com/2009/11/install- … armic.html

Re: Problem(Error) in ruby-on rails installtion

I tried the another method to install rubyonrails as follow but i got error


1) I  installed the ruby-1.9.2-p0  and rubygems-1.3.7  in the  (/usr/local/src directory )

2) Then i installed rails from terminal by typing follwoing

           sudo gem install rails --include-dependencies

3) Then i  made a rails applcation from terminal as

                        rails new demo
                             then
                       cd demo
                      ruby script/server

                       Here i got the error

            <internal:lib/rubygems/custom_require>:29:in `require': no such file to load -- script/../config/boot (LoadError)
    from <internal:lib/rubygems/custom_require>:29:in `require'
    from script/server:2:in `<main>'


4)The details of script/serve file are as under

   #!/usr/bin/env ruby
require File.dirname(__FILE__) + '/../config/boot'
require 'commands/server'


             Any suggesstion ??

thanks in advance

Re: Problem(Error) in ruby-on rails installtion

No need to install rubygems separately, they are already included with 19.2 Ruby version

Re: Problem(Error) in ruby-on rails installtion

well after visiting from no of blog ,i have solved this problem now i can show the welcome page at

                  localhost:3000

                                i have downloaded the source code of opensteetview(rails applcation ) , can anyone tell me how to run this source code at my computer

Thanks in advance again