Topic: PHPMyAdmin question...

Sorry, this doesn't have much to do with rails, but I can't get back to work until I have this fixed...

I can't, for the life of me, get phpmyadmin to work in Ubuntu Linux.  The lamp stack is fully installed and configured, but I keep getting this error when I try to authenticate in phpmyadmin:
#1045 - Access denied for user 'www-data'@'localhost' (using password: YES)

I have no clue what the www-data user is.  I have configured mysql with a root account which is what I always use.  So I'm using my root credentials to log in, but I get the error above.

Does anyone have some suggestions?  I've tried everything I can think of.  I've tried accessing the phpmyadmin app through localhost, ipaddress, domain, subdomain... same error every time.  It's a common error when I searched on google, but almost no solutions (in english).

Re: PHPMyAdmin question...

mysqladmin will try to login as the same account as the Web server (Apache?) is running. You should be able to browse to:

and change some of the details. A sample config is in the phpmyadmin directory under


Re: PHPMyAdmin question...

Thanks cwd.  Your suggestion led me to a solution.  Turns out that I'm having problems with cookie authentication.  I was trying to change it to HTTP authentication, but it wasn't taking effect.  I discovered that there are several files on my system.  The one that actually allows you to change to http authentication is here:  /var/lib/phpmyadmin/

I would have rather had cookie auth working, but this is way better than nothing.  Thanks again.