Topic: Please install the postgresql adapter: `gem install

i have a problem with postgres sql adapter .please give me solution . I am getting below
error

C:/Ruby187/lib/ruby/gems/1.8/gems/activerecord-2.3.5/lib/active_record/connection_adapters/abstract/connection_specification.rb:76:in
`establish_connection': Please install the postgresql adapter: `gem install
activerecord-postgresql-adapter` (no such file to load -- 1.8/pg_ext) (RuntimeError)

i am using
----------
ruby 1.8.7
rails 2.3.5
pg 0.9.0


in database.yml file:
----------------------
development:
  adapter: postgresql
  host: localhost
  username: postgres
  password: root
  database: oilwell7_development
  pool: 15
  encoding: utf8
  template: template0


But i have postgres_adapter.rb file


C:\Ruby187\lib\ruby\gems\1.8\gems\activerecord-2.3.5\lib\active_record\connection_adapters
but it says no such file to load .let me answer any one.

Thansk in advance

Re: Please install the postgresql adapter: `gem install

Copy your postgresql adapter file under C:\Ruby187\lib\ruby\gems\1.8\gems\activerecord-2.3.5\lib\active_record\connection_adapters