Topic: Ruby and rubygems installation error

Dear all,

I installed a ruby using the following command

sudo apt-get install ruby-full build-essential

Thus it shows ruby1.8 version in /usr/bin/ruby
Also, I installed rubygems using

sudo apt-get install rubygems.

Now when I try to update rubygems using

sudo gem update --systemNow

This gives a error message:
/usr/bin/gem:8:in `require': no such file to load -- rubygems (LoadError)
    from /usr/bin/gem:8

Also, when I try to run a project file which needs ruby and rubygems for installation it gives the error
/usr/bin/ruby1.8: no such file to load -- ubygems (LoadError)

How should I get rid of this error message? Could Anyone of you help me?