Topic: Strange error message

Hello,

I've had a Linux Ubunut production system that had a Ruby on Rails application running.
I'm relatively new to all of this deploying stuff, but the application was a rails2 application which had several gems locally frozen including the rails gems.

Because I needed to deploy a new application on the same server, written in rails 3 I installed all the gems I wanted on that server. Unfortunatly this broke the rails 2 application for some reason.
If you visit http://85.255.206.157/ you can see what I'm talking about...

I've removed ALL installed gems and reran the installation steps to get the system back as it was before I mingled with it. But still i'm receiving that error.
I'm really clueless as to what is going wrong...I've checked the logs 'production.log' but there's nothing usefull there as the application can't even fire up.

Some help would be nice....

Re: Strange error message

Can you post your production.log file contents please

It looks to me like you are not getting a Rails error but rather an apache error. It's almost as if the url knows nothing about the rails app but at the same time it knows to show a 500 internal server error.

Can you re-deploy your Rails 2 app?

Have you asked your host for help. all decent rails hosting companies will have an online chat facility with tech staff to help you out?

What you want and what you need are too often not the same thing!
When your head is hurting from trying to solve a problem, stop standing on it. When you are the right way up you will see the problem differently and you just might find the solution.
(Quote by me 15th July 2009)

Re: Strange error message

the production.log file contains nothing I'm afraid.
The server 500 problem has been resolved as well now.
mysql seems to be causing a fuss now and I have no idea why. Tried to google for the rrors but couldn't find anything that matches my scenario.

Sometimes I get the error about InnoDB not beeing supported, but there is no -skip-inno-db flag set anywhere
Sometimes I get the error about not beeing able to connect through a socket...but the files & dirs alle xist.

Re: Strange error message

finally solved it.
Apparently there was a second mysql running without privs and plugins for some reason.
Killed it and restarted the server.

Working like a charm now