Topic: [SOLVED] (Noob) Can't initialize rails server

Hello everyone, I'm quite sure it'sa noob question but let's get to the point:

I've installed:

Ruby 1.8.7
RubyGems 1.6.2
MySQL server 5.1.54

My gems' versions:

actionmailer (2.3.11)
actionpack (2.3.11)
activerecord (2.3.11)
activeresource (2.3.11)
activesupport (2.3.11)
i18n (0.4.2)
mysql (2.8.1)
rack (1.1.2)
rails (2.3.11)
rake (0.9.2)

Everything running in a VM with Ubuntu 11.04

Also I've got a stable version of redmine via svn

svn co http://redmine.rubyforge.org/svn/branches/1.2-stable redmine-1.2

The last thing I made:

rake db:migrate

and it was OK.

But now I'm trying to start the server so I learn more about rails developing.

But when I try

rails s or rails server

it creates a new project inside the projec's folder (called s or server)

(I'm more familiar with rails 3 but to change things on redmine I need to use version 2.3.11)

thanks in advance and sorry for such a freshman question.

Last edited by UsagiMD (2011-06-17 15:35:28)

Re: [SOLVED] (Noob) Can't initialize rails server

Oh I forgot to tell, these are the requirements for redmine: http://www.redmine.org/projects/redmine … ineInstall

Last edited by UsagiMD (2011-06-17 14:02:12)

Re: [SOLVED] (Noob) Can't initialize rails server

As I said, it was a noob question.

The solution:

use
ruby script/server

instead of:
rails s

It happened because I'm familiar with rails 3, I've mentioned it before.