Topic: Paperclip & Imagemagick Image Processing failure SOLVED

Hello.
Ive got a Rails 2.3.8 App
Ive just added image uploads as a feature, using Paperclip 2.3.16 (GEM)
Everything works fine in Development mode.

When switching to production mode, everything works EXCEPT any processing of the image.
That is, i can save any original image uploaded. but if i add any :style to the attachments the post processing fails and the error i get looks like the thing below, which unfortunately doesn't tell me much:

Parameters: {......... "image"=>#<File:/tmp/RackMultipart20110829-24764-15pxgl2-0>}}

[paperclip] An error was received while processing: #<Paperclip::PaperclipError: There was an error processing the thumbnail for stream20110829-24764-1xx7tvo-0>

Ive been playing around with Imagemagick & Paperclip settings and installed the latest version of Imagemagick on my Server. although im not sure that Rails / Paperclip is using this new version when its being called..

Any help would be appreciated.
Thanks


----- I solved this by changing one of my Styles from:

:thumb =>"48x48^"

to

:thumb =>"48x48#"

And now it all works. so perhaps this is just a failure of that particular resize geometry thing in Imagemagick.

Last edited by ssgrfk (2011-08-31 07:21:54)