Topic: Matchit in Vim/Ruby

Hi!

I just installed Vim (7.0.164 - compiled with Ruby scripting support) and then I installed the Vim/Ruby (2007.03.02) gem. I executed the vim-ruby-install.rb script and added the following lines to my ~/.vimrc

set nocompatible          " We're running Vim, not Vi!
syntax on                 " Enable syntax highlighting
filetype plugin indent on " Enable filetype-specific indenting and plugins

" Load matchit (% to bounce from do to end, etc.)
runtime! macros/matchit.vim

augroup myfiletypes
  " Clear old autocmds in group
  autocmd!
  " autoindent with two spaces, always expand tabs
  autocmd FileType ruby,eruby,yaml set ai sw=2 sts=2 et
augroup END


Omni completion and autoindent work very well!

But matchit does not. When I type Shift+Enter, the block is not automatically closed.

Did I miss something?

Thanks!

Last edited by Jonathan M (2007-04-05 18:10:41)