Topic: Installation of JQuery failed help

I have tried to install JQuery

I have all the scripts under "public/javascripts" and I also added gem 'jquery-rails' into gem file. but when I type in bundle install or gem install 'jquery-rails' it displays an error 'could not find a valid gem 'jquery-rails' ()= 0 ) in any repository. I also tried to specify the gem like gem 'jquery-rails', '>= 0.2.7' but it didn't work.

Please help

Last edited by faith (2011-12-04 09:35:48)

Re: Installation of JQuery failed help

What version of Rails are you using?
Rails 3.1 uses jQuery by default

Your Gemfile declaration should simply be

gem 'jquery-rails'

Which is what you say you had.
Make sure you are running ruby 1.9.2 at least and Rails 3.x

What you want and what you need are too often not the same thing!
When your head is hurting from trying to solve a problem, stop standing on it. When you are the right way up you will see the problem differently and you just might find the solution.
(Quote by me 15th July 2009)