Topic: Newbie Question

I installed Ruby 1.9.3 per the instructions in a treehouse tutorial.  I believe I did so successfully.  Now when I check Ruby -v in my terminal it shows that I have 1.8.7...but right after I installed it I was correctly showed 1.9.3.  I ran rvm install 1.9.3 and it told me it was already installed (as I previously thought).  But when I check the version manager it still tells me I'm using 1.8.7. 

Haven't installed Rails yet (I don't think!)...b/c I'm trying to figure out I did wrong w/ this part.  Anyone have any idea what I'm doing wrong. 

I'm completely new to programming.  Just breaking in.  Going threw Learn Ruby the Hard Way now (Ch. 16).  Previously did lessons on HTML, CSS, and the few they have on Ruby in Treehouse.  I plan on trying Rails for Zombies after I finish this Learn Ruby...

So if anyone has an explanation for someone that knows just a notch above nothing about the problem I'm having I would be grateful. 

Thanks in advance.

Re: Newbie Question

did you do a

rvm use 1.9.2

before you did

ruby -v

Joe got a job, on the day shift, at the Utility Muffin Research Kitchen, arrogantly twisting the sterile canvas snout of a fully charged icing anointment utensil.

Re: Newbie Question

That did it Brad.  Thank you very much.  Any 'right way to learn' ruby on rails advice/resources for someone that's new to programming but eager to try?

Re: Newbie Question

Ryan Bates Railscasts are an excellent resource, I highly recommend them.

Good old Google will also find you lots of answers.

Be sure to check the version of rails in any tutorial you try and follow,  if your on Rails 3.1.X,  make sure the tutorial is written for 3.1.X,  most are old,  and things won't work right if you try and follow,  Rails has changed a lot starting with 3.X.

Joe got a job, on the day shift, at the Utility Muffin Research Kitchen, arrogantly twisting the sterile canvas snout of a fully charged icing anointment utensil.