Topic: Error installing Rails on Ubuntu 11.10 (Gem::DependencyError)

I'm trying to install Ruby on Rails on Ubuntu 11.10, but receiving this error:

    $ sudo gem install rails
    ERROR:  While executing gem ... (Gem::DependencyError)
        Unable to resolve dependencies: rails requires activesupport (= 3.2.3), actionpack (= 3.2.3), activerecord (= 3.2.3), activeresource (= 3.2.3), actionmailer (= 3.2.3), railties (= 3.2.3)


How can I fix this?

Note: Git (1.7.5.4 ) and Ruby (1.9.2p290) are installed properly.

Re: Error installing Rails on Ubuntu 11.10 (Gem::DependencyError)

Instead of trying to sudo install Rails, I would recommend that you install on your user account using RVM. The link below takes you to a pretty good set of instructions for getting up and running with RVM and Rails.

http://blog.sudobits.com/2011/10/27/how … ntu-11-10/