Topic: [BUG] Bus Error

I am going through the the Ruby on Rails tutorial and I am trying to run my first application. When I type in 'rails server' I keep getting this error...


/Users/jherrlin/.rvm/gems/ruby-1.9.3-p125/gems/json-1.6.6/ext/json/ext/json/ext/parser.bundle: [BUG] Bus Error
ruby 1.8.7 (2012-02-08 patchlevel 358) [i686-darwin9]

Abort trap

How do I fix this? I am fairly new to all of this.

Re: [BUG] Bus Error

try

rvm use 1.9.3

then try again.

It looks like you're running rvm (ruby version manager),  and you have two versions of ruby installed (1.8.7 and 1.9.3).   You select ruby versions with the rvm use command.  My guess is that you 'used' 1.9.3,  then installed gems for 1.9.3,  then came back later and ended up using ruby 1.8.7 and tried to boot the server.

Last edited by BradHodges (2012-04-01 13:13:10)

Joe got a job, on the day shift, at the Utility Muffin Research Kitchen, arrogantly twisting the sterile canvas snout of a fully charged icing anointment utensil.