Topic: SOLVED translation missing error despite locale yml file

I got an error message when submitting a form after validating for missing values:
"translation missing: fr, activerecord, errors, template, body"

I updated my default fr.yml file by doing a copy paste from: … ils/locale

After doing this I had a lot of syntax errors in my fr.yml file. I had to remove all the tab characters and replaced them automatically by spaces.

I still got the same translation missing error and I don't know what else to do.

All I know is that I have a tremendous trouble updating my fr.yml file because whenever I try to update something it gets systematically rejected with a syntax error, and I always managed so far to tweak the issue by playing around and retyping again and again some parts of the file. I would want a more consistent way to edit and update this file with no syntax errors.

Last edited by carrot06 (2012-04-11 10:02:36)

Re: SOLVED translation missing error despite locale yml file

yml is very sensitive to spaces and indentation level achieved via spaces,  you can't use tabs,  it has to be spaces,  and you have to make sure you keep everything at the correct indentation level.  If sounds like your editor automatically replaced multiple spaces with tabs during the copy/paste.  Try just downloading the file instead of copy and paste,  or see if you can turn off space/tab replacement in your editor.

Joe got a job, on the day shift, at the Utility Muffin Research Kitchen, arrogantly twisting the sterile canvas snout of a fully charged icing anointment utensil.

Re: SOLVED translation missing error despite locale yml file

The indentation was incorrect. I fixed it and it worked. Thanks