Topic: InstantRail 1.7 Help on XP

I installed InstantRail 1.7 many hours ago (I guess it is not so instant after all). It took a while (over an hour) to unzip the file (127MB and 18,270 files). I followed the following steps to run InstantRails:

1. unzipped the files in E:\InstantRails
2. Ran InstantRails.exe (it asked me to create the configurations files, which I did).
      Received following errors:
        a). "inetinfo" is already using port 80.
           I fixed it by changing the port number in Apache configuration file to 3080.
        b). There was an error related to Directory Path in the Apache Configuration file
           I fixed it by editing E:/InstantRails/conf_files/http.conf file line 311 to
                      DocumentRoot "${path}/www" to DocumentRoot "${path}"
3. Edited Windows/hosts file to put "" line

4. Restarted the servers "I > Restart Servers", noticed that both Apache and MySQL were running fine.

5. Open a console window to check the version information:
a). Ruby version is:
E:\InstantRails>ruby -v
ruby 1.8.6 (2007-03-13 patchlevel 0) [i386-mswin32]

b). Rails version
E:\InstantRails>rails -v
E:/InstantRails/ruby/bin/rails:9:in `require': no such file to load -- rubygems
        from E:/InstantRails/ruby/bin/rails:9
To fix the above error I set the following environment variable in XP:

Now I get the following error:
E:\InstantRails\rails_apps>rails -v
E:\InstantRails\ruby\bin\ruby.exe: no such file to load -- ubygems (LoadError)

Can some help how to fix this error?


Last edited by rxjain (2007-04-15 02:23:59)

Re: InstantRail 1.7 Help on XP

Hello m8 it seems like its not installed properly. Try installing manually. Check this website out