Topic: “large” image files not getting saved using paperclip in production

Uploading and resizing images of any size works flawlessly on my desktop running development and productions modes. On my server running an apache/passenger setup any image file over 1 MB returns one of two errors

Command :: identify -format %wx%h '/tmp/243.jpg20120504-2852-ryheox[0]'
Command :: convert '/tmp/243.jpg20120504-2852-ryheox[0]' -resize "400x400" '/tmp/24320120504-2852-l69yg'
[paperclip] An error was received while processing: #<Paperclip::Error: There was an error processing the thumbnail for 243>
Command :: identify -format %wx%h '/tmp/243.jpg20120504-2852-ryheox[0]'
Command :: convert '/tmp/243.jpg20120504-2852-ryheox[0]' -resize "200x200" '/tmp/24320120504-2852-g957f'
[paperclip] An error was received while processing: #<Paperclip::Error: There was an error processing the thumbnail for 243>

or

Command :: identify -format %wx%h '/tmp/046.jpg20120504-946-1w1106[0]'
[paperclip] An error was received while processing: #<Paperclip::Errors::NotIdentifiedByImageMagickError: /tmp/046.jpg20120504-946-1w1106 is not recognized by the 'identify' command.>
Command :: identify -format %wx%h '/tmp/046.jpg20120504-946-1w1106[0]'
[paperclip] An error was received while processing: #<Paperclip::Errors::NotIdentifiedByImageMagickError: /tmp/046.jpg20120504-946-1w1106 is not recognized by the 'identify' command.>

Smaller files have no issues.

I have about 3 GB free disk space and when trying to upload files my free memory never drops below 60MB and there is 300MB of swap space.

Is there some special setting I am missing? The environment production file is whatever was generated when the rails app was created.

I can upload video files in excess of 50MB and just store them. The server is using ImageMagick 6.7.2-0