Topic: Running old rails app on nginx, unicorn and rbenv

Hi,

I have a VPS on which I run several rails apps ranging from 1.3.5, 2.3.9 and 3.2. Although everything works fine on RVM, Passenger and Apache, I really would like to experiment a bit with nginx, rbenv and unicorn.

So far everything from 2.3.9 to 3.x works fine using unicorn etc. But it is the really old ones that are difficult.

I use this script to make a rails 1.3.5 app a rack app: https://gist.github.com/424352. If I add the unicorn config file, and the nginx conf file for the app I can make it run with unicorn_rails. But......

What I really would like is to run unicorn_rails with the local ruby version which I specified with rbenv. For rails apps who use bundle you would generate binstubs, so I can start unicorn_rails from within the app (using the specified ruby version for the app). But since 1.3.5 isn't a bundle-app, there is no way I can think of to generate binstubs.

Is it possible to run unicorn_rails, respecting the locally specified ruby version????

Thanks in advance

Casper