Topic: Phusion Passenger Installation on Mac OS X 10.7.5

When I run the command, "sudo passenger-install-apache2-module", I get the following error message:

ALICEs-MacBook-Air-2:~ alicewang$ sudo passenger-install-apache2-module
Password:
/Users/alicewang/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/dependency.rb:247:in `to_specs': Could not find passenger (>= 0) amongst [bigdecimal-1.1.0, io-console-0.3, json-1.5.4, minitest-2.5.1, rake-0.9.2.2, rdoc-3.9.4] (Gem::LoadError)
    from /Users/alicewang/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/dependency.rb:256:in `to_spec'
    from /Users/alicewang/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems.rb:1231:in `gem'
    from /Users/alicewang/.rvm/gems/ruby-1.9.3-p194/bin/passenger-install-apache2-module:18:in `<main>'
    from /Users/alicewang/.rvm/gems/ruby-1.9.3-p194/bin/ruby_noexec_wrapper:14:in `eval'
    from /Users/alicewang/.rvm/gems/ruby-1.9.3-p194/bin/ruby_noexec_wrapper:14:in `<main>'

Last edited by dnlwng (2012-10-03 00:05:55)

Re: Phusion Passenger Installation on Mac OS X 10.7.5

Just some background information:

Using Ruby 1.9.3p194
Using Rails 3.2.8
Using Gem 1.8.24
Using Passenger 3.0.24