Topic: mysql and mongrel do not startup after reboot?

Hi everyone,
I have a working ubuntu server deployed using capistrano and deprec. after the initial installation everything worked fine - but after rebooting only the apache server (httpd) started and mysql/mongrel were down. It seems that in rc2.d everything is set up find (there are symlinks to mysql and mongrel_cluster, and when I call them manually they start up alright) but they are not executed.

also, I see the is ps -ef "init [2]" is still running. The last time I actually worked on a unix server is 4 years ago, and I can't remember if that means initialization is still running (and stuck) or that it jsut stays up this way.

can anyone please help? this is really annoying! smile


Re: mysql and mongrel do not startup after reboot?

You should always have an init process (process ID 1.)  Did you install mysql with apt-get or Synaptic?  That should be running automatically.  If your rc scripts are correct, it seems very strange that they wouldn't be running after a reboot. - Brewery and Brewpub management powered by RoR

Re: mysql and mongrel do not startup after reboot?

they were installed using deprec and capistrano...
I think it uses apt-get, but on the other hand it builds apache from source so I'm not so sure...