Topic: [solved] Running first app under apache

Hi, everyone
I have to apologize for my English

openSUSE 11.4
Apache 2.2.17
Passenger 3.0.18
Ruby 1.8.7
Rails 3.2.8

I have already installed RoR application under apache - ChiliProject (but using rails 2.3.14) and it works fine. It's installed in /chiliproject and In httpd config I have "RailsBaseURI /chiliproject/public".
Now, I need to develop own application (actually, first experience in web developing).
"rails new hello_world", Webrick works fine, but I want to run it under apache with CGI. I added in httpd conf "RailsBaseURI /hello_world/public". But it doesn't work properly. When I press "About your application environment" on index page it gives me 404 "The page you were looking for doesn't exist.". For any routes in rails it gives either error 500 or 404. But same routes and controllers work fine with webrick. And even if I put ChiliProject into /hello_world it works. This means that problem is not with apache or passenger.
I read on the ruby website that 1.8.7 may cause crashes with rails3. Shame... I spent 4 hours working arounf RVM and different rub versions. After all, ChiliProject (even lates version) doesn't work with ruby 1.9 and my original problem did not gone. Now I have all thing back (ruby 1.8.7 from distro's repo and no RVM).
btw, this hello_world is here
Thanks in advance

Last edited by FlySnake (2012-11-21 07:06:24)

Re: [solved] Running first app under apache

Solved … n-same-env

The problem is that passenger by default runs production environment. You have to specify "RailsEnv development" in host cfg to run development