Topic: installation problem with ruby

i have installed ruby, rails and also gems. gems were installed using cmd 'gem install rails --include-dependencies --no-rdoc --no-ri'

but while running the server i am receiving the error as:

C:\Users\sujith\Railsapps\my_apps>rails server
C:/Ruby193/lib/ruby/gems/1.9.1/gems/execjs-1.4.0/lib/execjs/runtimes.rb:51:in `
utodetect': Could not find a JavaScript runtime. See https://github.com/sstephe
son/execjs for a list of available runtimes. (ExecJS::RuntimeUnavailable)
        from C:/Ruby193/lib/ruby/gems/1.9.1/gems/execjs-1.4.0/lib/execjs.rb:5:i
`<module:ExecJS>'
        from C:/Ruby193/lib/ruby/gems/1.9.1/gems/execjs-1.4.0/lib/execjs.rb:4:i
`<top (required)>'
        from C:/Ruby193/lib/ruby/gems/1.9.1/gems/coffee-script-2.2.0/lib/coffee
script.rb:1:in `require'
        from C:/Ruby193/lib/ruby/gems/1.9.1/gems/coffee-script-2.2.0/lib/coffee
script.rb:1:in `<top (required)>'
        from C:/Ruby193/lib/ruby/gems/1.9.1/gems/coffee-script-2.2.0/lib/coffee
script.rb:1:in `require'
        from C:/Ruby193/lib/ruby/gems/1.9.1/gems/coffee-script-2.2.0/lib/coffee
script.rb:1:in `<top (required)>'
        from C:/Ruby193/lib/ruby/gems/1.9.1/gems/coffee-rails-3.2.2/lib/coffee-
ails.rb:1:in `require'
        from C:/Ruby193/lib/ruby/gems/1.9.1/gems/coffee-rails-3.2.2/lib/coffee-
ails.rb:1:in `<top (required)>'
        from C:/Ruby193/lib/ruby/gems/1.9.1/gems/bundler-1.2.3/lib/bundler/runt
me.rb:68:in `require'
        from C:/Ruby193/lib/ruby/gems/1.9.1/gems/bundler-1.2.3/lib/bundler/runt
me.rb:68:in `block (2 levels) in require'
        from C:/Ruby193/lib/ruby/gems/1.9.1/gems/bundler-1.2.3/lib/bundler/runt
me.rb:66:in `each'
        from C:/Ruby193/lib/ruby/gems/1.9.1/gems/bundler-1.2.3/lib/bundler/runt
me.rb:66:in `block in require'
        from C:/Ruby193/lib/ruby/gems/1.9.1/gems/bundler-1.2.3/lib/bundler/runt
me.rb:55:in `each'
        from C:/Ruby193/lib/ruby/gems/1.9.1/gems/bundler-1.2.3/lib/bundler/runt
me.rb:55:in `require'
        from C:/Ruby193/lib/ruby/gems/1.9.1/gems/bundler-1.2.3/lib/bundler.rb:1
8:in `require'
        from C:/Users/sujith/Railsapps/my_apps/config/application.rb:7:in `<top
(required)>'
        from C:/Ruby193/lib/ruby/gems/1.9.1/gems/railties-3.2.9/lib/rails/comma
ds.rb:53:in `require'
        from C:/Ruby193/lib/ruby/gems/1.9.1/gems/railties-3.2.9/lib/rails/comma
ds.rb:53:in `block in <top (required)>'
        from C:/Ruby193/lib/ruby/gems/1.9.1/gems/railties-3.2.9/lib/rails/comma
ds.rb:50:in `tap'
        from C:/Ruby193/lib/ruby/gems/1.9.1/gems/railties-3.2.9/lib/rails/comma
ds.rb:50:in `<top (required)>'
        from script/rails:6:in `require'
        from script/rails:6:in `<main>'


I have installed the indicating gem(execjs) also.... but it is not sloved..... GUYS PLZ HELP ME IN THIS ROBLEM

Re: installation problem with ruby

That's a problem related to not having a nodejs interpreter in you command path. I am on Linux not windows so I am not sure if this will work but try adding

gem 'execjs'
gem 'therubyracer'

then

$ bundle install
$ rails s

Hope that helps