Topic: IBM_DB connection fail

I really cannot figure it out . When I try to connect with db2 (ibm_db) and start server
it gives me error like this below
I did before gem install ibm_db and change gemfile.

C:\Dev\mmls-rb>rails server
C:/Dev/Ruby193/lib/ruby/gems/1.9.1/gems/ibm_db-2.5.11-x86-mingw32/lib/mswin32/ib
m_db.rb:1:in `require': 126: 지정된 모듈을 찾을 수 없습니다. (module could not be found)  - C:/Dev/Ruby193/
lib/ruby/gems/1.9.1/gems/ibm_db-2.5.11-x86-mingw32/lib/mswin32/rb19x/ibm_db.so (
LoadError)
        from C:/Dev/Ruby193/lib/ruby/gems/1.9.1/gems/ibm_db-2.5.11-x86-mingw32/l
ib/mswin32/ibm_db.rb:1:in `<top (required)>'
        from C:/Dev/Ruby193/lib/ruby/gems/1.9.1/gems/ibm_db-2.5.11-x86-mingw32/l
ib/ibm_db.rb:1:in `require'
        from C:/Dev/Ruby193/lib/ruby/gems/1.9.1/gems/ibm_db-2.5.11-x86-mingw32/l
ib/ibm_db.rb:1:in `<top (required)>'
        from C:/Dev/Ruby193/lib/ruby/gems/1.9.1/gems/bundler-1.2.3/lib/bundler/r
untime.rb:68:in `require'
        from C:/Dev/Ruby193/lib/ruby/gems/1.9.1/gems/bundler-1.2.3/lib/bundler/r
untime.rb:68:in `block (2 levels) in require'
        from C:/Dev/Ruby193/lib/ruby/gems/1.9.1/gems/bundler-1.2.3/lib/bundler/r
untime.rb:66:in `each'
        from C:/Dev/Ruby193/lib/ruby/gems/1.9.1/gems/bundler-1.2.3/lib/bundler/r
untime.rb:66:in `block in require'
        from C:/Dev/Ruby193/lib/ruby/gems/1.9.1/gems/bundler-1.2.3/lib/bundler/r
untime.rb:55:in `each'
        from C:/Dev/Ruby193/lib/ruby/gems/1.9.1/gems/bundler-1.2.3/lib/bundler/r
untime.rb:55:in `require'
        from C:/Dev/Ruby193/lib/ruby/gems/1.9.1/gems/bundler-1.2.3/lib/bundler.r
b:128:in `require'
        from C:/Dev/mmls-rb/config/application.rb:7:in `<top (required)>'
        from C:/Dev/Ruby193/lib/ruby/gems/1.9.1/gems/railties-3.2.11/lib/rails/c
ommands.rb:53:in `require'
        from C:/Dev/Ruby193/lib/ruby/gems/1.9.1/gems/railties-3.2.11/lib/rails/c
ommands.rb:53:in `block in <top (required)>'
        from C:/Dev/Ruby193/lib/ruby/gems/1.9.1/gems/railties-3.2.11/lib/rails/c
ommands.rb:50:in `tap'
        from C:/Dev/Ruby193/lib/ruby/gems/1.9.1/gems/railties-3.2.11/lib/rails/c
ommands.rb:50:in `<top (required)>'
        from script/rails:6:in `require'
        from script/rails:6:in `<main>'



What is wrong? What should i do for correction? any ideas??

Last edited by jiun suk (2013-02-01 11:25:44)