Topic: install rails on windows

hello,

i am new to rails. i want to install rails in a PC in LAN.

First I installed Ruby by rubyinstaller-1.9.3-p392.exe, and installed RubyGems in rubygems-1.8.25.zip.

The last step, according to the tips from "http://rubyonrails.org/download" is - gem install rails.

I think that rails will be installed automatically by gem which fetch files from the remote "rubygems.org".  It seems not.

It indicated an error: unable to resolve dependencies.

What should i do to install rails successfully and quickly? (I don't want to download each gem and its dependencies and install it. )


thanks

Last edited by infososo (2013-04-11 21:29:34)

Re: install rails on windows

What is your OS ? If you're on Windows you can use RailsInstaller (railsinstaller.org), download it, run install, and everything is set for you to use rails (ie, Rails, Ruby and all the needed stuff)

Re: install rails on windows

thanks anso.

I've tried the railsinstaller-2.2.1.exe. After the rail's install finished, i run a command "rails new myRailsApp" to create a new app.

An error occured when running command "run  bundle install". it is "Fetching source index from https://rubygems.org/. Could not fetch specs from https://rubygems.org/".

Re: install rails on windows

Hi infososo
Not sure what this happens (I installed via railsinstaller many times on my system with  no problem).
I guess there's a conflict with the previous installations (Ruby by rubyinstaller-1.9.3-p392.exe, and installed RubyGems in rubygems-1.8.25.zip.).
I suggest to uninstall all the stuff and make a clean new install via RailsInstaller

Re: install rails on windows

i would describe the installation in detail.

we plan to use Redmine in project management. According to Redmine installation's requirement, the Rails should be installed.

i have a server machine in LAN. It can not access the Internet.

The first installation is using railsinstaller-2.2.1.exe. It failed with the above mentioned error. I think it is caused because the machine can not create a connection with the server "https://rubygems.org/".

The second installtion is to install rubyinstaller-1.9.3-p392.exe, then RubyGems and rails. It failed too. I think the reason is same.

The latest installation, i downloaded rails-3-2-13.zip. unzip it, go into the directory, run "gem install rails".
rails-3-2-13>gem install rails
ERROR:  Could not find a valid gem 'rails' (>= 0) in any repository
ERROR:  While executing gem ... (Gem::RemoteFetcher::FetchError)
    too many connection resets (http://rubygems.org/latest_specs.4.8.gz)

The zip file should include all gems which rails needed.

how should use this file?