Topic: Backporting to a previous version of Rails

I am currently running v 1.2.1 on my local Windows machine and I need to backport to 1.1.6.  How do I do this?

The reason I'm doing this is because Joyent is running 1.1.6 and my app is in 1.2.1 and it won't deploy.  They told me to freeze Rails and then redeploy, but that didn't work, so I'm going with the backport option.

Re: Backporting to a previous version of Rails

If you have Rails 1.1.6 installed on your computer you can specify the version you want to use in your environment.rb file:

# place near top of environment.rb
RAILS_GEM_VERSION = '1.1.6'

Railscasts - Free Ruby on Rails Screencasts

Re: Backporting to a previous version of Rails

I changed the environment.rb file and when I go to load the server, I'm getting an error:

c:/ruby/lib/ruby/site_ruby/1.8/rubygems.rb:196: in 'activate': can't activate rails (= 1.2.1), already activated rails-1.1.6] (Gem::Exception)


Hmmmmm.