Topic: application failed to start

I had my application up and running then I kept getting 502 Proxy Errors on Media Temple about 10 mins after starting the app so I thought I configured something wrong and started over. Now when I enter "mtr start APPNAME" I get this:

Error executing command:
application failed to start, check /home/XXXX/containers/rails/APPNAME/shared/log/mongrel.log for errors

When I tail the log file this comes up:

/home/XXXX/data/rubygems/gems/gems/mongrel-1.0.1-i386-linux/lib/mongrel/configurator.rb:270:in `each'
/home/XXXX/data/rubygems/gems/gems/mongrel-1.0.1-i386-linux/lib/mongrel/configurator.rb:270:in `run'
/home/XXXX/data/rubygems/gems/gems/mongrel-1.0.1-i386-linux/bin/mongrel_rails:127:in `run'
/home/XXXX/data/rubygems/gems/gems/mongrel-1.0.1-i386-linux/lib/mongrel/command.rb:211:in `run'
/home/XXXX/data/rubygems/gems/gems/mongrel-1.0.1-i386-linux/bin/mongrel_rails:243
/home/XXXX/data/rubygems/gems/bin/mongrel_rails:16:in `load'
/home/XXXX/data/rubygems/gems/bin/mongrel_rails:16Waiting for 3 requests to finish, could take 60 seconds.
Sat May 26 22:01:44 -0700 2007: Reaping 1 threads for slow workers because of 'shutdown'
Thread #<Thread:0xb756892c sleep> is too old, killing.

Can somone tell me how to fix this? The date, Sat May 26, is from when it was last running yesterday and no new messages are appearing when I try to start the app.

Last edited by freaky (2007-05-27 15:23:36)

Re: application failed to start

whats in the production log files.

also I used media temple in the past they are quite good and solving errors in the customer service. just open up a new ticket.

--

Re: application failed to start

Hi BasicMind,

Thanks for your help. Here's what's showing up in the last 80 lines or so of production.log:

ActionController::MissingFile (Cannot read file /home/XXXX/containers/rails/simplelog/current/config/../themes/custom/stylesheets/print.css):
    /vendor/rails/actionpack/lib/action_controller/streaming.rb:59:in `send_file'
    /vendor/plugins/theme_support/lib/theme_controller.rb:29:in `render_theme_item'
    /vendor/plugins/theme_support/lib/theme_controller.rb:9:in `stylesheets'
    /vendor/rails/actionpack/lib/action_controller/base.rb:1095:in `send'
    /vendor/rails/actionpack/lib/action_controller/base.rb:1095:in `perform_action_without_filters'
    /vendor/rails/actionpack/lib/action_controller/filters.rb:632:in `call_filter'
    /vendor/rails/actionpack/lib/action_controller/filters.rb:638:in `call_filter'
    /vendor/rails/actionpack/lib/action_controller/filters.rb:449:in `call'
    /vendor/rails/actionpack/lib/action_controller/filters.rb:637:in `call_filter'
    /vendor/rails/actionpack/lib/action_controller/filters.rb:619:in `perform_action_without_benchmark'
    /vendor/rails/actionpack/lib/action_controller/benchmarking.rb:66:in `perform_action_without_rescue'
    /usr/lib/ruby/1.8/benchmark.rb:293:in `measure'
    /vendor/rails/actionpack/lib/action_controller/benchmarking.rb:66:in `perform_action_without_rescue'
    /vendor/rails/actionpack/lib/action_controller/rescue.rb:83:in `perform_action'
    /vendor/rails/actionpack/lib/action_controller/base.rb:430:in `send'
    /vendor/rails/actionpack/lib/action_controller/base.rb:430:in `process_without_filters'
    /vendor/rails/actionpack/lib/action_controller/filters.rb:624:in `process_without_session_management_support'
    /vendor/rails/actionpack/lib/action_controller/session_management.rb:114:in `process'
    /vendor/rails/actionpack/lib/action_controller/base.rb:330:in `process'
    /vendor/rails/railties/lib/dispatcher.rb:41:in `dispatch'
    /home/XXXX/data/rubygems/gems/gems/mongrel-1.0.1-i386-linux/lib/mongrel/rails.rb:78:in `process'
    /home/XXXX/data/rubygems/gems/gems/mongrel-1.0.1-i386-linux/lib/mongrel/rails.rb:76:in `synchronize'
    /home/XXXX/data/rubygems/gems/gems/mongrel-1.0.1-i386-linux/lib/mongrel/rails.rb:76:in `process'
    /home/XXXX/data/rubygems/gems/gems/mongrel-1.0.1-i386-linux/lib/mongrel.rb:618:in `process_client'
    /home/XXXX/data/rubygems/gems/gems/mongrel-1.0.1-i386-linux/lib/mongrel.rb:617:in `each'
    /home/XXXX/data/rubygems/gems/gems/mongrel-1.0.1-i386-linux/lib/mongrel.rb:617:in `process_client'
    /home/XXXX/data/rubygems/gems/gems/mongrel-1.0.1-i386-linux/lib/mongrel.rb:736:in `run'
    /home/XXXX/data/rubygems/gems/gems/mongrel-1.0.1-i386-linux/lib/mongrel.rb:736:in `initialize'
    /home/XXXX/data/rubygems/gems/gems/mongrel-1.0.1-i386-linux/lib/mongrel.rb:736:in `new'
    /home/XXXX/data/rubygems/gems/gems/mongrel-1.0.1-i386-linux/lib/mongrel.rb:736:in `run'
    /home/XXXX/data/rubygems/gems/gems/mongrel-1.0.1-i386-linux/lib/mongrel.rb:720:in `initialize'
    /home/XXXX/data/rubygems/gems/gems/mongrel-1.0.1-i386-linux/lib/mongrel.rb:720:in `new'
    /home/XXXX/data/rubygems/gems/gems/mongrel-1.0.1-i386-linux/lib/mongrel.rb:720:in `run'
    /home/XXXX/data/rubygems/gems/gems/mongrel-1.0.1-i386-linux/lib/mongrel/configurator.rb:271:in `run'
    /home/XXXX/data/rubygems/gems/gems/mongrel-1.0.1-i386-linux/lib/mongrel/configurator.rb:270:in `each'
    /home/XXXX/data/rubygems/gems/gems/mongrel-1.0.1-i386-linux/lib/mongrel/configurator.rb:270:in `run'
    /home/XXXX/data/rubygems/gems/gems/mongrel-1.0.1-i386-linux/bin/mongrel_rails:127:in `run'
    /home/XXXX/data/rubygems/gems/gems/mongrel-1.0.1-i386-linux/lib/mongrel/command.rb:211:in `run'
    /home/XXXX/data/rubygems/gems/gems/mongrel-1.0.1-i386-linux/bin/mongrel_rails:243
    /home/XXXX/data/rubygems/gems/bin/mongrel_rails:16:in `load'
    /home/XXXX/data/rubygems/gems/bin/mongrel_rails:16

    Mongrel timed out this thread: shutdown
    /home/XXXX/data/rubygems/gems/gems/mongrel-1.0.1-i386-linux/lib/mongrel.rb:675:in `write'
    /home/XXXX/containers/rails/simplelog/current/config/../vendor/rails/activerecord/lib/active_record/vendor/mysql.rb:532:in `write'
    /home/XXXX/containers/rails/simplelog/current/config/../vendor/rails/activerecord/lib/active_record/vendor/mysql.rb:506:in `command'
    /home/XXXX/containers/rails/simplelog/current/config/../vendor/rails/activerecord/lib/active_record/vendor/mysql.rb:238:in `close'
    /home/XXXX/containers/rails/simplelog/current/config/../vendor/rails/activerecord/lib/active_record/connection_adapters/mysql_adapter.rb:236:in `disconnect!'
    /home/XXXX/containers/rails/simplelog/current/config/../vendor/rails/activerecord/lib/active_record/connection_adapters/mysql_adapter.rb:231:in `reconnect!'
    /home/XXXX/containers/rails/simplelog/current/config/../vendor/rails/activerecord/lib/active_record/connection_adapters/abstract_adapter.rb:93:in `verify!'
    /home/XXXX/containers/rails/simplelog/current/config/../vendor/rails/activerecord/lib/active_record/connection_adapters/abstract/connection_specification.rb:109:in$
    /home/XXXX/containers/rails/simplelog/current/config/../vendor/rails/activerecord/lib/active_record/connection_adapters/abstract/connection_specification.rb:108:in$
    /home/XXXX/containers/rails/simplelog/current/config/../vendor/rails/activerecord/lib/active_record/connection_adapters/abstract/connection_specification.rb:108:in$
    /home/XXXX/containers/rails/simplelog/current/config/../vendor/rails/railties/lib/dispatcher.rb:111:in `prepare_application'
    /home/XXXX/containers/rails/simplelog/current/config/../vendor/rails/railties/lib/dispatcher.rb:39:in `dispatch'
    /home/XXXX/data/rubygems/gems/gems/mongrel-1.0.1-i386-linux/lib/mongrel/rails.rb:78:in `process'
    /home/XXXX/data/rubygems/gems/gems/mongrel-1.0.1-i386-linux/lib/mongrel/rails.rb:76:in `synchronize'
    /home/XXXX/data/rubygems/gems/gems/mongrel-1.0.1-i386-linux/lib/mongrel/rails.rb:76:in `process'
    /home/XXXX/data/rubygems/gems/gems/mongrel-1.0.1-i386-linux/lib/mongrel.rb:618:in `process_client'
    /home/XXXX/data/rubygems/gems/gems/mongrel-1.0.1-i386-linux/lib/mongrel.rb:617:in `each'
    /home/XXXX/data/rubygems/gems/gems/mongrel-1.0.1-i386-linux/lib/mongrel.rb:617:in `process_client'
    /home/XXXX/data/rubygems/gems/gems/mongrel-1.0.1-i386-linux/lib/mongrel.rb:736:in `run'
    /home/XXXX/data/rubygems/gems/gems/mongrel-1.0.1-i386-linux/lib/mongrel.rb:736:in `initialize'
    /home/XXXX/data/rubygems/gems/gems/mongrel-1.0.1-i386-linux/lib/mongrel.rb:736:in `new'
    /home/XXXX/data/rubygems/gems/gems/mongrel-1.0.1-i386-linux/lib/mongrel.rb:736:in `run'
    /home/XXXX/data/rubygems/gems/gems/mongrel-1.0.1-i386-linux/lib/mongrel.rb:720:in `initialize'
    /home/XXXX/data/rubygems/gems/gems/mongrel-1.0.1-i386-linux/lib/mongrel.rb:720:in `new'
    /home/XXXX/data/rubygems/gems/gems/mongrel-1.0.1-i386-linux/lib/mongrel.rb:720:in `run'
    /home/XXXX/data/rubygems/gems/gems/mongrel-1.0.1-i386-linux/lib/mongrel/configurator.rb:271:in `run'
    /home/XXXX/data/rubygems/gems/gems/mongrel-1.0.1-i386-linux/lib/mongrel/configurator.rb:270:in `each'
    /home/XXXX/data/rubygems/gems/gems/mongrel-1.0.1-i386-linux/lib/mongrel/configurator.rb:270:in `run'
    /home/XXXX/data/rubygems/gems/gems/mongrel-1.0.1-i386-linux/bin/mongrel_rails:127:in `run'
    /home/XXXX/data/rubygems/gems/gems/mongrel-1.0.1-i386-linux/lib/mongrel/command.rb:211:in `run'
    /home/XXXX/data/rubygems/gems/gems/mongrel-1.0.1-i386-linux/bin/mongrel_rails:243
    /home/XXXX/data/rubygems/gems/bin/mongrel_rails:16:in `load'
    /home/XXXX/data/rubygems/gems/bin/mongrel_rails:16


I was running out of things to try so I tried reinstalling everything on my account because I thought something may not have been installed right. Now when I go to install the mysql drivers I get this:

DOMAIN.com@cl26:/home/XXXX/data$ gem install mysql --source=http://gems.mediatemple.net/
Bulk updating Gem source index for: http://gems.mediatemple.net/
Select which gem to install for your platform (i386-linux)
1. mysql 2.7.3 (mswin32)
2. mysql 2.7.1 (mswin32)
3. mysql 2.7 (i386-linux)
4. mysql 2.7 (ruby)
5. Skip this gem
6. Cancel installation
> 4
Building native extensions.  This could take a while...
ERROR:  While executing gem ... (Gem::Installer::ExtensionBuildError)
    ERROR: Failed to build gem native extension.

ruby extconf.rb install mysql - --source=http://gems.mediatemple.net/
checking for mysql_query() in -lmysqlclient... no
checking for main() in -lm... no
checking for mysql_query() in -lmysqlclient... no
checking for main() in -lz... no
checking for mysql_query() in -lmysqlclient... no
checking for main() in -lsocket... no
checking for mysql_query() in -lmysqlclient... no
checking for main() in -lnsl... no
checking for mysql_query() in -lmysqlclient... no
*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of
necessary libraries and/or headers.  Check the mkmf.log file for more
details.  You may need configuration options.

Provided configuration options:
        --with-opt-dir
        --without-opt-dir
        --with-opt-include
        --without-opt-include=${opt-dir}/include
        --with-opt-lib
        --without-opt-lib=${opt-dir}/lib
        --with-make-prog
        --without-make-prog
        --srcdir=.
        --curdir
        --ruby=/usr/bin/ruby
        --with-mysql-config
        --without-mysql-config
        --with-mysql-dir
        --without-mysql-dir
        --with-mysql-include
        --without-mysql-include=${mysql-dir}/include
        --with-mysql-lib
        --without-mysql-lib=${mysql-dir}/lib
        --with-mysqlclientlib
        --without-mysqlclientlib
        --with-mlib
        --without-mlib
        --with-mysqlclientlib
        --without-mysqlclientlib
        --with-zlib
        --without-zlib
        --with-mysqlclientlib
        --without-mysqlclientlib
        --with-socketlib
        --without-socketlib
        --with-mysqlclientlib
        --without-mysqlclientlib
        --with-nsllib
        --without-nsllib
        --with-mysqlclientlib
        --without-mysqlclientlib


Gem files will remain installed in /home/XXXX/data/rubygems/gems/gems/mysql-2.7 for inspection.
Results logged to /home/XXXX/data/rubygems/gems/gems/mysql-2.7/gem_make.out


Any ideas?

I opened a ticket with MT and they replied back stating that they only support the technology on the server and wouldn't offer any help.

Re: application failed to start

yes when I installed everything I chose the i386-linux options not the ruby ones. that worked for me

--

Re: application failed to start

So you didn't choose ANY of the ruby options? I thought that was supposed to be selected. It's strange they didn't specify what to choose in Media Temple's tutorial on how to set up RoR on the (gs).

Do you have any idea what is wrong with the first bit of code that I posted?

Re: application failed to start

Mongrel timed out this thread: shutdown

Mongrel is getting shutdown.