Topic: ERROR: While executing gem ... (URI::InvalidURIError)

I'm trying to install Rails on OS X 10.4.10, but whenever I use the command "sudo gem install" I get this error message:

ERROR:  While executing gem ... (URI::InvalidURIError)
    can not set user with registry or opaque

Can anyone tell me what this means and what I can do to fix or work around it?  Thanks.

Re: ERROR: While executing gem ... (URI::InvalidURIError)

Short answer is I have no idea.  But, you might want to check to see what version of ruby you have.  OS X by default install 1.8.2 while many gems require 1.8.4 to work.  Just a thought..