Topic: Acts_as_ferret only returns results when searching for "*"

Hey, I'm probably just missing something really obvious but I've been stuck on this problem for a while now and I'm not getting anywhere.

I have installed the acts_as_ferret gem, as well as ferret according to the tutorial on RailsEnvy.  My model, controller, and environment.rb files have all been modified as per that turotial.  However any attempts to use the find_by_contents on my model returns 0 results unless I am doing Article.find_by_contents("*"), with Article being my model.

In the Article model I have the "acts_as_ferret" with no fields specified as I was under the impression that this would index all fields.  I've also tried specifying specific fields which still yielded the same error.

Has anyone else run into this problem?

Re: Acts_as_ferret only returns results when searching for "*"

Try deleting the index files.
Your rails project has a folder called index. Delete the folders you find in there.
(there is probably a cleaner way to delete your old index but this did the trick for me)