Topic: Permission Denined...(script/plugin)

Please help, I use locomotive on a Mac.

when i try to install a plug-in, say i use this in terminal
/script/plugin install svn://errtheblog.com/svn/plugins/will_paginate

returns me "-bash: script/plugin: Permission denied"

then I try to add sudo in front of it.
it returns me
"sudo: script/plugin: command not found"

them I try to add sudo ruby in front of it...

then it returns me
"/Applications/Locomotive2/Bundles/standardRailsMar2007.locobundle/powerpc/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/commands/plugin.rb:258: warning: Insecure world writable dir /Users/User/Documents/20dreamer in PATH, mode 040777
sh: line 1: svn: command not found"

I got no clues and any idea of solving this....Please help...I am now stucked in the middle...

Thanks!!!

Re: Permission Denined...(script/plugin)

chmod u+x scripts/*

That will let you run it without being root but you will need to install SVN to use the plugin installer.

Last edited by shadow (2007-08-06 07:42:39)

Re: Permission Denined...(script/plugin)

thx so much!~