Topic: Application hanging in production! NewRelic Phy Mem Utilization bad!

Hi all,
My app was doing fairly well in production past couple a months. But past 2 days, its gone off its rocker! Not able to figure out what the problem is. The symptoms are as follows..

- It first went down when I deployed and ran a migration yesterday. A simple column addition to a table
- The production log showed the SignalException::SIGTERM error ( dont know anything about it )
- a server reboot seems to solve the problem temporarily
- New Relic RPM shows wayward physical mem utilization.
- im on Slicehost and the 'free' command shows way too much SWAP memory usage (which is basically not good)

Does it sound like im having a memory leak? anywhere i could look? anything i can do??
Oh those who have fought the battle and come out victorious.. bestow upon me ur knowledge! big_smile
Seriously.. any pointers?

Thanks!

Re: Application hanging in production! NewRelic Phy Mem Utilization bad!

Hi Vinay,
I'm also having this same f**kng problem past 2 days.
Its killing me. Have you fixed this problem?? do plz.

Re: Application hanging in production! NewRelic Phy Mem Utilization bad!

millisami, if you have any daemons or crons running on your server, you might want to check those. stop them and see if the mem utilization improves.

Re: Application hanging in production! NewRelic Phy Mem Utilization bad!

Can you provider the output of: sar -A

It outputs a lot of data so feel free to get with me offline and I'll be glad to check your VPS.

Best

FULLY managed everything because we care.
Dedicated Servers at UNIXy - https://www.unixy.net
Virtual Private Servers at VPSLux - http://www.vpslux.com
joe@unixy.net. Feel free to get in touch. I unsubscribe from threads overnight.