Topic: Webby

I'm having a bit of a problem installing webby. I get this error when i type

webby-gen website mysite

/usr/local/lib/ruby/gems/1.9.1/gems/webby-0.9.4/lib/webby.rb:104:in `require': /usr/local/lib/ruby/gems/1.9.1/gems/webby-0.9.4/lib/webby/core_ext/string.rb:15: invalid multibyte char (US-ASCII) (SyntaxError)
/usr/local/lib/ruby/gems/1.9.1/gems/webby-0.9.4/lib/webby/core_ext/string.rb:15: invalid multibyte char (US-ASCII)
/usr/local/lib/ruby/gems/1.9.1/gems/webby-0.9.4/lib/webby/core_ext/string.rb:15: syntax error, unexpected $end, expecting ')'
    parts = self.split( %r/( [:.;?!][ ] | (?:[ ]|^)["â] )/x )
                                                       ^
        from /usr/local/lib/ruby/gems/1.9.1/gems/webby-0.9.4/lib/webby.rb:104:in `block in require_all_libs_relative_to'
        from /usr/local/lib/ruby/gems/1.9.1/gems/webby-0.9.4/lib/webby.rb:104:in `each'
        from /usr/local/lib/ruby/gems/1.9.1/gems/webby-0.9.4/lib/webby.rb:104:in `require_all_libs_relative_to'
        from /usr/local/lib/ruby/gems/1.9.1/gems/webby-0.9.4/lib/webby.rb:150:in `<top (required)>'
        from /usr/local/lib/ruby/gems/1.9.1/gems/webby-0.9.4/bin/webby-gen:37:in `require'
        from /usr/local/lib/ruby/gems/1.9.1/gems/webby-0.9.4/bin/webby-gen:37:in `<top (required)>'
        from /usr/bin/webby-gen:19:in `load'
        from /usr/bin/webby-gen:19:in `<main>'

What have I done wrong? sad

Last edited by rubynewbie (2009-10-25 18:51:19)

Re: Webby

I seem to have fixed it now. I typed in "# encoding: utf-8" in the string.rb file.

Although its fixed I do get a new error message coming up, seems to only be a warning but I'm not sure how to stop it coming up

warning: undefining `object_id' may cause serious problem

Re: Webby

hello everyone. I'm having problems when trying to use webby. First I had the same error shown above, follow the hint and could use the command webby-gen my_site website, but the error persists when trying to use the command webby, follows
(resource.rb: 13: warning: undefining `object_id 'may cause serious problems)

following part of the document. If a good soul help me I will be very grateful. =) Bye

  / home/bankai/.rvm/gems/ruby-1.9.3-p374/gems/webby-0.9.4/lib/webby/resources/resource.rb

# Encoding: utf-8
unless defined? Webby :: Resources :: Resource

module Webby :: Resources

# The Webby :: Resource is any file That can be found in the content directory
# Or in the layout directory. This class contains information about the
# Resources available to Webby.
#
Resource class

   instance_methods.each the | m |
       undef_method (m) unless m = ~% r / \ A__ | \? $ / | |
                              m == 'class'
   end