Topic: scaffold css will NOT go away

i have been tearing my hair out with this.  im not sure when it started, but i notice now that peices of scaffold.css are loading with my app.

when i look in firebug under css, in the list of .css files, it lists just 'localhost:3000'.  No specific css file mentioned.

i have long ago removed the call to load the scaffold.css file from layout, however for the sake of testing, i deleted everything from the layout except for <%= yield %> and those styles still load.

even stranger.....
my scaffold.css looks like this...

body { background-color: #fff; color: #333; }

body, p, ol, ul, td {
  font-family: verdana, arial, helvetica, sans-serif;
  font-size:   13px;
  line-height: 18px;
}

pre {
  background-color: #eee;
  padding: 10px;
  font-size: 11px;
}

a { color: #000; }
a:visited { color: #666; }
a:hover { color: #fff; background-color:#000; }

.fieldWithErrors {
  padding: 2px;
  background-color: red;
  display: table;
}

#errorExplanation {
  width: 400px;
  border: 2px solid red;
  padding: 7px;
  padding-bottom: 12px;
  margin-bottom: 20px;
  background-color: #f0f0f0;
}

#errorExplanation h2 {
  text-align: left;
  font-weight: bold;
  padding: 5px 5px 5px 15px;
  font-size: 12px;
  margin: -7px;
  background-color: #c00;
  color: #fff;
}

#errorExplanation p {
  color: #333;
  margin-bottom: 0;
  padding: 5px;
}

#errorExplanation ul li {
  font-size: 12px;
  list-style: square;
}

HOWEVER....
the loading styles that show up labeled as 'localhost:3000' look like this...

    body { background-color: #fff; color: #333; }

    body, p, ol, ul, td {
      font-family: verdana, arial, helvetica, sans-serif;
      font-size:   13px;
      line-height: 18px;
    }

    pre {
      background-color: #eee;
      padding: 10px;
      font-size: 11px;
    }

    a { color: #000; }
    a:visited { color: #666; }
    a:hover { color: #fff; background-color:#000; }

it is only the top half of it.

any ideas with this?  is there some cache i need to purge or something?  its driving me mad...

Re: scaffold css will NOT go away

Just curious ... move scaffold.css to oldscaffold.css and see what it does.

Also, since the css is not specific to a file (just localhost:3000), do you have any inline styles like <style>...</style> when you view page source?

Re: scaffold css will NOT go away

AHH!
when i was checking my source before, i didnt see anything....
but after a 2nd look, inside of a <li> tag....i found

<html xmlns="http://www.w3.org/1999/xhtml">
<head>
  <title>Action Controller: Exception caught</title>
  <style>
    body { background-color: #fff; color: #333; }

    body, p, ol, ul, td {
      font-family: verdana, arial, helvetica, sans-serif;
      font-size:   13px;
      line-height: 18px;
    }

    pre {
      background-color: #eee;
      padding: 10px;
      font-size: 11px;
    }

    a { color: #000; }
    a:visited { color: #666; }
    a:hover { color: #fff; background-color:#000; }
  </style>

</head>
<body>

<h1>Unknown action</h1>
<p>No action responded to table. Actions: create, destroy, edit, index, new, show, and update</p>


</body>
</html>

which led me to a missing active scaffolding declaration in my controller.

How frustrating!
thank you for directing me back to my source!