Topic: Rails requires RubyGems >= 1.3.1 to run my application
My application is running with Rails 2.0.2
It works fine on my machine.
There is Rails 2.0.2 installed (and Rails 1.2.3 too) but when I try to deploy it on this server, when I do
ruby script/server -e production -p 3000
I have this error:
Rails requires RubyGems >= 1.3.1 (you have 0.9.4). Please `gem update --system` and try again."
The admin of the server is telling me that if he updates RubyGems, then people using Rails 1.2.3 on the same server will have some problems.
But I wonder why the version of RubyGem matters? Is RubyGem not supposed to be only a package manager? Why is the version involved when I run an application? And how updating Rubygem would break Rails 1.2.3?