Topic: Cucumber and Rspec - English:Case, English:Style and Facets

Running Rails 2.3.5 on Ruby 1.9.1 and using Cucumber 0.4.4, Rspec  1.2.9 and Webrat 0.6.0 and am getting the following message whenever I run cucumber

English::Case is being deprecated. Use Facets instead (except #namecase).
English::Stylize is being deprecated. Use Facets instead.

A quick Google revealed nothing useful. Does anyone know what might be causing this and how to fix it? I'm having some other issues, on which I will likely be posting shortly, that could conceivably be related and want to get this out of the way if I can.


Re: Cucumber and Rspec - English:Case, English:Style and Facets

Showing some code that triggers this might actually help people help you. We're not wizards.

Re: Cucumber and Rspec - English:Case, English:Style and Facets

I know you're not wizards, but I thought that someone might have seen this specific warning before. I would have included code if I thought that this was connected to something specific to the application code, but this gets returned anytime I run cucumber or spec on any of my projects (should've mentioned before that rspec alone brings up the warning, so it seems really to be an rspec issue). Even the most basic spec triggers it -

require File.dirname(__FILE__) + '/../spec_helper'

describe Newsletter do
  before(:each) do
  describe "sending emails" do

Loaded Helper (comments removed):

Dir[File.expand_path(File.join(File.dirname(__FILE__),'support','**','*.rb'))].each {|f| require f}
Spec::Runner.configure do |config|
  config.use_transactional_fixtures = true
  config.use_instantiated_fixtures  = false
  config.fixture_path = RAILS_ROOT + '/spec/fixtures/'

Test Config (most comments removed):

config.cache_classes = true

# Log error messages when you accidentally call methods on nil.
config.whiny_nils = true

# Show full error reports and disable caching
config.action_controller.consider_all_requests_local = true
config.action_controller.perform_caching             = false
config.action_view.cache_template_loading            = true

# Disable request forgery protection in test environment
config.action_controller.allow_forgery_protection    = false

config.action_mailer.delivery_method = :test

# Set the website adress for the test environment

config.gem "webrat"
config.gem "cucumber"
config.gem "email_spec"
config.gem "factory_girl"
config.gem "rspec", :lib => "spec"
config.gem "rspec-rails", :lib => false

Does anything look out of order there?


Re: Cucumber and Rspec - English:Case, English:Style and Facets

Because of all the issues I had while working with RSpec and Cucumber with ruby1.9 I went ahead and installed ZenTest so that I could use multiruby to manage my ruby versions al a this post - … multiruby.

Running on ruby 1.8.7 I don't get those any warnings any longer, so the evidence mounts that this was just a ruby1.9 thing, though it may be more specifically related to the older version of test-unit which is required when working with ruby1.9.

Just thought I could this updated for anyone else who comes across this.


Re: Cucumber and Rspec - English:Case, English:Style and Facets

This happened to me also after adding to my rails config/environment.rb
config.gem 'english', :version => '= 0.4.0'

Commenting that out removed the warnings.

Re: Cucumber and Rspec - English:Case, English:Style and Facets

Hmm... I wondering if an older version of cucumber may have put that line in for me - if it did it was probably removed when I upgraded my system as I recall having to regenerate cucumber on at least a few of my projects. I still have my old hard drive though, so one of these days I may boot up from it and see what was going on back then. Thanks for confirming that I'm not the only person to have seen this warning.