Topic: just installed instantrails, can't start new application

I am very frustrated. I just installed instant rails, after I create a new application. click the button 'start with mongrel', the console started for 10 second, then automatically closed by itself. couldn't start up the new application. I couldn't figure out why. I have no problem starting cookbook with mongrel. Anyone could help? please!

Last edited by Grace (2007-02-04 19:01:08)

Re: just installed instantrails, can't start new application

So just to clarify things a bit, you have installed Instant Rails probably on a Windows box and your using Rad Rails as the editor and you can't view your application in the browser.

In the console after starting the mongrel server I get the following

** Starting Mongrel listening at 0.0.0.0:3000
** Starting Rails with development environment...
** Rails loaded.
** Loading any Rails specific GemPlugins
** Signals ready.  INT => stop (no restart).
** Mongrel available at 0.0.0.0:3000
** Use CTRL-C to stop.

Are you seeing something different?

Re: just installed instantrails, can't start new application

I can't see anything, because the console window shut down automatically. I am new to ruby. what i did is I followed 'Rolling With Ruby On Instant Rails Tutorial', installed instantrails and mysql, then I click 'create new Rails app', run 'rails demo', then I came back, click the "start with mongrel", the console window open up for "demo", just for very short time. nothing came up in the console window yet, the window shut down by itself. I down't know what step I missed or....

Re: just installed instantrails, can't start new application

Can you put up a link to the tutorial you followed?

Re: just installed instantrails, can't start new application

http://instantrails.rubyforge.org/wiki/ … s_Tutorial

Hi, Sydney
Here is the link to the tutorial. I could run the sample "cookbook", click the 'start with mongrel', the console window for 'cookbook', running fine and it stay open, and I can see the code you post here. but not with new Rails app. Do you know what's wrong?

Grace