Topic: selenium-webdriver wont install...please help

Afternoon,

I am pulling my hair out trying to install selenium-webdriver gem on my snow leopard machine....currently I have installed libffi using port but am still getting the following error:

shorts-pc:~ sarndeepnijjar$ sudo gem install selenium-webdriver-0.0.24.gem
Building native extensions.  This could take a while...
ERROR:  Error installing selenium-webdriver-0.0.24.gem:
    ERROR: Failed to build gem native extension.

/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/ruby extconf.rb
checking for ffi_call() in -lffi... no
checking for ffi_raw_call()... no
checking for rb_thread_blocking_region()... no
creating extconf.h
creating Makefile

make
Configuring libffi for rch
configure: WARNING: If you wanted to set the --build type, don't use --host.
    If a cross compiler is detected then cross compile mode will be used.
Invalid configuration `rch-apple-darwin': machine `rch-apple' not recognized
configure: error: /bin/sh /Library/Ruby/Gems/1.8/gems/ffi-0.6.3/ext/ffi_c/libffi/config.sub rch-apple-darwin failed
make[1]: *** No targets specified and no makefile found.  Stop.
Configuring libffi for rch
configure: WARNING: If you wanted to set the --build type, don't use --host.
    If a cross compiler is detected then cross compile mode will be used.
Invalid configuration `rch-apple-darwin': machine `rch-apple' not recognized
configure: error: /bin/sh /Library/Ruby/Gems/1.8/gems/ffi-0.6.3/ext/ffi_c/libffi/config.sub rch-apple-darwin failed
make[1]: *** No targets specified and no makefile found.  Stop.
make: *** [/Library/Ruby/Gems/1.8/gems/ffi-0.6.3/ext/ffi_c/libffi/.libs/libffi_convenience.a] Error 2



does anyone know what i need to do to get it to work?