Topic: Is OS X 10.4.7 version of ruby still broken?

I am new to both Ruby on Rails world and the OS X world. I have read that Ruby that ships with OS X is broken but all the wright ups seem dated (old).  Is Ruby still broken in the latest version of OS X?  I would like it if I would not have to go thru all the gyrations to fix Ruby if possible. Thanks

Re: Is OS X 10.4.7 version of ruby still broken?

I'm assuming it is as I haven't heard otherwise. I know it is broken in 10.4.6 and below. I would just follow these instructions.

Railscasts - Free Ruby on Rails Screencasts

Re: Is OS X 10.4.7 version of ruby still broken?

ryanb wrote:

I'm assuming it is as I haven't heard otherwise. I know it is broken in 10.4.6 and below. I would just follow these instructions.

It was fixed in 10.4.6

apple wrote:

The version of Ruby that shipped on Mac OS X Tiger prior to v10.4.6 did not work well with Rails.   If you're running an earlier version of Tiger, you'll need to either upgrade to 10.4.6 or upgrade your copy of Ruby to version 1.8.4 or later using the open source distribution.

http://developer.apple.com/tools/rubyonrails.html

vinnie - rails forum admin

Re: Is OS X 10.4.7 version of ruby still broken?

vin wrote:

It was fixed in 10.4.6

Sorry for the wrong info. I guess I should have looked it up instead of relying on my memory. smile

I probably had some other reason for compiling ruby on 10.4.6. Can't remember now though.

Railscasts - Free Ruby on Rails Screencasts

Re: Is OS X 10.4.7 version of ruby still broken?

ryanb wrote:
vin wrote:

It was fixed in 10.4.6

Sorry for the wrong info. I guess I should have looked it up instead of relying on my memory. smile

The only reason I know is because my Mac came with 10.4.6 and I did a ruby -v before trying to install it myself smile

ryanb wrote:

I probably had some other reason for compiling ruby on 10.4.6. Can't remember now though.

A beta version perhaps?

vinnie - rails forum admin

Re: Is OS X 10.4.7 version of ruby still broken?

vin wrote:

A beta version perhaps?

Hmm, I don't think so. Does history work with irb in 10.4.6/7 (using up arrow to run previous commands)? Maybe that was the reason. Or perhaps I'm actually thinking of 10.4.5. Who knows. smile

Railscasts - Free Ruby on Rails Screencasts