Topic: First steps: superclass mismatch

Hi guys,

just doing my first steps with ruby and ror. besides some theoretical
learning i wanted to setup typo as a development blog and kind of a ror
playground.

I use plesk 8 on a debian sarge machine with ruby on rails support
installed into plesk 8. I updated to 1.8.5 manually and ruby -v says
1.8.5 is perfectly installed. I also installed rubygems and with that
rails, typo and the dependent stuff.

i also think i'm already aware of the structure of ror applications and
setup a subdomain within plesk with httpdocs of the subdomain beeing a
symbolic link to a folder "typo/public" within my subdomainfolder where
the typo installations resides. i got typo installed via "gem install
typo" and "typo install /my/path/..."

so far so good.

Starting script/server or public/dispatch.cgi brings up:

# ruby script/server
./script/../config/../vendor/rails/activesupport/lib/active_support/ordered_options.rb:28:
superclass mismatch for class OrderedOptions (TypeError)
        from
./script/../config/../vendor/rails/activesupport/lib/active_support/dependencies.rb:364:in
`require'
        from
./script/../config/../vendor/rails/activesupport/lib/active_support/dependencies.rb:364:in
`require'
        from
./script/../config/../vendor/rails/activesupport/lib/active_support.rb:37
        from
./script/../config/../vendor/rails/railties/lib/commands/server.rb:1:in
`require'
        from
./script/../config/../vendor/rails/railties/lib/commands/server.rb:1
        from script/server:3:in `require'
        from script/server:3

i found similar errors all around the net but either they were really
old or didn't get any answer. I hope to find help here.

Thanks for your support.