Topic: HTTP Response 302 fetching...

Hi, I have problem with rails update I've installed mac os x 10.5.6 and wanted to update rails from Rails 1.2.6 to something above I have Ruby 1.8.6 and wanted to update it to 1.9, first of all as I understand I have to update rubygems, no luck, terminal always gives me out this 'error ERROR:  While executing gem ... (Gem::RemoteSourceException)
    HTTP Response 302 fetching http://gems.rubyforge.org/yaml', why am I getting this error and what should I do to fix it and update my rails, thanks.

Re: HTTP Response 302 fetching...

Hello,
I am new to rails community. I am getting this error when try to installing gem install -v=1.2.3 rails & for other gems also.
error is: While executing gem ... (Gem::RemoteSourceException)
HTTP Response 302 fetching http://gems.rubyforge.org/yaml'
Pl help me regarding this issue .It will be great help.
Thanks.

Re: HTTP Response 302 fetching...

try

gem update --system

then try again

Joe got a job, on the day shift, at the Utility Muffin Research Kitchen, arrogantly twisting the sterile canvas snout of a fully charged icing anointment utensil.

Re: HTTP Response 302 fetching...

Brad -  I have the same problem these guys are reporting and when I do what you say:

gem update --system

I get the error message again:


ERROR:  While executing gem ... (Gem::RemoteSourceException)
    HTTP Response 302 fetching http://gems.rubyforge.org/yaml

Re: HTTP Response 302 fetching...

I am having this same error. I have seen some people fix the problem by downloading the current RubyGems. However, I don't know how to